libdmx: Add fso-specs to DEPENDS
[openembedded.git] / recipes / v86d / v86d_0.1.8.bb
blob934e71cd23adb26ebc4efb75c920b66499ab78f1
1 DESCRIPTION = "User support binary for the uvesafb kernel module"
2 SRC_URI = "http://dev.gentoo.org/~spock/projects/uvesafb/archive/v86d-${PV}.tar.bz2 \
3 file://fbsetup"
4 DEPENDS = "virtual/kernel klibc"
5 LICENSE = "GPLv2"
6 PR = "r0"
8 RRECOMMENDS_${PN} = "kernel-module-uvesafb"
10 PACKAGE_ARCH = "${MACHINE_ARCH}"
11 COMPATIBLE_HOST = 'i.86.*-linux'
13 INITSCRIPT_NAME = "fbsetup"
14 INITSCRIPT_PARAMS = "start 0 S ."
16 export CC=${TARGET_PREFIX}klcc
18 # klcc doesn't work with -isystem
19 export TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}/${layout_includedir}"
21 do_configure () {
22 ./configure --default
25 do_compile () {
26 KDIR="${STAGING_KERNEL_DIR}" make
29 do_install () {
30 install -d ${D}${base_sbindir}
31 install v86d ${D}${base_sbindir}/
33 install -d ${D}${sysconfdir}/init.d/
34 install -m 0755 ${WORKDIR}/fbsetup ${D}${sysconfdir}/init.d/fbsetup
37 inherit update-rc.d
39 SRC_URI[md5sum] = "613c601d6a8a85289327ef6392e16c57"
40 SRC_URI[sha256sum] = "4154c5a3830bba25bd63b175f4fba07867ef029124d8c9470fac45235569dde5"