libdmx: Add fso-specs to DEPENDS
[openembedded.git] / recipes / usrp / usrp_0.12.bb
blob774520c71238ce5e90bf8838b439aea635325040
1 DESCRIPTION = "Support software for the Universal Software Radio Peripheral (USRP)"
2 LICENSE = "GPL"
3 HOMEPAGE = "http://comsec.com/wiki?UniversalSoftwareRadioPeripheral"
4 SECTION = "devel"
5 DEPENDS = "swig-native sdcc-native virtual/libusb0 python boost"
6 RDEPENDS = "python-core"
7 PR = "r1"
9 SRC_URI = "ftp://ftp.gnu.org/gnu/gnuradio/old/usrp-${PV}.tar.gz \
10 file://fix_compile_h.patch;patch=1;pnum=3 \
11 file://install_test.patch;patch=1"
13 SRC_URI[md5sum] = "41ee5d5f1ef440fdd880f99c53fccf69"
14 SRC_URI[sha256sum] = "c9be448984840ae960874c3c536942ba63c79a7f6a0dff3970540190b1500804"
16 SRC_URI_append_omap5912osk = "file://usb11.patch;patch=1"
18 S = "${WORKDIR}/usrp-${PV}"
20 inherit autotools pkgconfig python-dir
22 CXXFLAGS_powerpc += "-lstdc++"
24 export BUILD_SYS := "${BUILD_SYS}"
25 export HOST_SYS := "${HOST_SYS}"
27 do_stage () {
28 oe_libinstall -so -C host/lib/.libs/ libusrp ${STAGING_LIBDIR}
30 install -m 644 host/lib/usrp_basic.h ${STAGING_INCDIR}
31 install -m 644 host/lib/usrp_bytesex.h ${STAGING_INCDIR}
32 install -m 644 host/lib/usrp_config.h ${STAGING_INCDIR}
33 install -m 644 host/lib/usrp_dbid.h ${STAGING_INCDIR}
34 install -m 644 host/lib/usrp_prims.h ${STAGING_INCDIR}
35 install -m 644 host/lib/usrp_slots.h ${STAGING_INCDIR}
36 install -m 644 host/lib/usrp_standard.h ${STAGING_INCDIR}
38 install -m 644 firmware/include/usrp_i2c_addr.h ${STAGING_INCDIR}
39 install -m 644 firmware/include/usrp_spi_defs.h ${STAGING_INCDIR}
42 PACKAGES += "python-pyusrp-dbg python-pyusrp"
43 FILES_python-pyusrp-dbg += "${PYTHON_SITEPACKAGES_DIR}/.debug"
44 FILES_python-pyusrp = "${libdir}/python*"