libdmx: Add fso-specs to DEPENDS
[openembedded.git] / recipes / tasks / task-x11.bb
blobdb45ab93809b825c0cc80de334d2563beccc9b17
1 DESCRIPTION = "The X Window System -- install this task to get a client/server based display multiplexer."
2 SECTION = "x11/server"
3 LICENSE = "MIT"
4 PV = "1.0"
5 PR = "r3"
7 # WORK IN PROGRESS
9 inherit task
11 PACKAGES += "\
12 ${PN}-server \
13 ${PN}-utils \
16 RRECOMMENDS_${PN} = "\
17 ${PN}-server \
18 ${PN}-utils \
21 # Some machines don't set a *runtime* provider for X, so default to Xfbdev here
22 # virtual/xserver won't work, since the kdrive recipes will build multiple xserver packages
23 XSERVER ?= "xserver-kdrive-fbdev"
25 # This is also the reason why we have to make this package machine specific :/
26 PACKAGE_ARCH_${PN}-server = "${MACHINE_ARCH}"
28 RDEPENDS_${PN}-server = "\
29 ${XSERVER} \
32 RDEPENDS_${PN}-utils = "\
33 xserver-kdrive-common \
34 xserver-nodm-init \
35 xauth \
36 xhost \
37 xset \
38 xrandr \