1 DESCRIPTION
= "SHR Lite Image Feed"
8 PACKAGE_ARCH
= "${MACHINE_ARCH}"
10 def get_rdepends
(bb
, d
):
11 enabled
= bb.
data.getVar
("ENABLE_BINARY_LOCALE_GENERATION", d
, 1)
13 #
If locale is disabled
, bail out
17 locales
= bb.
data.getVar
("GLIBC_GENERATE_LOCALES", d
, 1)
18 if not locales
or locales
== "all":
19 locales
= bb.
data.getVar
("IMAGE_LINGUAS", d
, 1);
21 libc
= bb.
data.getVar
('LIBC'
, d
, 1)
25 if not locales
or locales
== "all":
26 #
if locales aren't specified
, or user has written
"all"
28 ipkdir
= bb.
data.getVar
('DEPLOY_DIR_IPK'
, d
, 1)
30 regexp1
= re.compile
(libc
+"-binary-localedata-.*") # search pattern
31 regexp2
= re.compile
("_.*") # we want
to remove all version info
and file extension
33 for root
, subFolders
, files in os.walk
(ipkdir
):
35 if regexp1.search
(file
):
36 file
= regexp2.sub
("", file
)
37 rdepends
= "%s %s" % (rdepends
, file
)
40 #
if locales are specified
41 regexp1
= re.compile
("\\..*") # We want
to turn en_US.UTF
-8 into en_US
42 regexp2
= re.compile
("_") # We want
to turn en_US into en
-US
45 for locale in locales.split
(" "):
46 locale
= regexp1.sub
("", locale
)
47 locale
= regexp2.sub
("-", locale
)
48 locale
= str.
lower(locale
)
49 rdepends
= "%s %s-binary-localedata-%s" % (rdepends
, libc
, locale
)
67 RDEPENDS_$
{PN
}-base
= "\
68 ${MACHINE_TASK_PROVIDER} \
74 modutils-initscripts \
75 module-init-tools-depmod \
84 RDEPENDS_$
{PN
}-cli
= "\
89 RDEPENDS_$
{PN
}-fso
= "\
98 #FIXME
: libcanberra
-alsa should be pulled in by fsodeviced but isn't
99 RDEPENDS_$
{PN
}-audio
= "\
101 alsa-utils-alsamixer \
107 RDEPENDS_$
{PN
}-x
= "\
109 task-fonts-truetype-core \
113 xcursor-transparent-theme \
115 # Needed for proper input support in efl based apps
117 # All localedata based on IMAGE_LINGUAS
118 ${@get_rdepends(bb, d)} \
119 # Make sure it's available for those who want's to play with illume2
120 e-wm-config-illume2-shr \
123 RDEPENDS_$
{PN
}-apps
= "\
124 task-fso2-compliance \
125 phoneui-apps-messages \
126 phoneui-apps-contacts \
127 phoneui-apps-dialer \
128 phoneui-apps-quick-settings \
140 RDEPENDS_$
{PN
}-gtk
= "\
141 shr-theme-gtk-e17lookalike \
144 matchbox-keyboard-im \