1 DESCRIPTION
= "MokoGateway: Tasks for a companion server for the Openmoko Linux Distribution"
3 PROVIDES
= "task-mokogateway-everything"
9 task-mokogateway-everything \
10 ${MOKOGATEWAY_PACKAGES} \
13 MOKOGATEWAY_PACKAGES
= "\
14 task-mokogateway-usbnet \
15 task-mokogateway-bluetooth \
16 task-mokogateway-wifi \
17 task-mokogateway-debug \
20 RDEPENDS_task
-mokogateway
-everything
= "${MOKOGATEWAY_PACKAGES}"
22 DESCRIPTION_task
-mokogateway
-usbnet
= "MokoGateway: USB Networking"
23 RDEPENDS_task
-mokogateway
-usbnet
= "\
26 RRECOMMENDS_task
-mokogateway
-usbnet
= "\
27 kernel-module-usbnet \
28 kernel-module-cdc-acm \
29 kernel-module-cdc-ether \
30 kernel-module-iptable-nat \
31 kernel-module-ipt-masquerade \
34 DESCRIPTION_task
-mokogateway
-bluetooth
= "MokoGateway: Bluetooth"
35 RDEPENDS_task
-mokogateway
-bluetooth
= "\
38 RRECOMMENDS_task
-mokogateway
-bluetooth
= "\
39 kernel-module-bluetooth \
41 kernel-module-rfcomm \
42 kernel-module-hci-vhci \
45 kernel-module-hci-uart \
47 ${@base_contains("COMBINED_FEATURES
", "usbhost
", "kernel
-module
-hci
-usb
", "",d)} \
48 ${@base_contains("COMBINED_FEATURES
", "pcmcia
", "kernel
-module
-bluetooth3c
-cs
", "",d)} \
49 ${@base_contains("COMBINED_FEATURES
", "pcmcia
", "kernel
-module
-bluecard
-cs
", "",d)} \
50 ${@base_contains("COMBINED_FEATURES
", "pcmcia
", "kernel
-module
-bluetoothuart
-cs
", "",d)} \
51 ${@base_contains("COMBINED_FEATURES
", "pcmcia
", "kernel
-module
-dtl1
-cs
", "",d)} \
54 DESCRIPTION_task
-mokogateway
-wifi
= "MokoGateway: WiFi"
55 RDEPENDS_task
-mokogateway
-wifi
= "\
58 ${@base_contains("COMBINED_FEATURES
", "madwifi
", "madwifi
-ng
-modules
", "",d)} \
59 ${@base_contains("COMBINED_FEATURES
", "madwifi
", "madwifi
-ng
-tools
", "",d)} \
62 RRECOMMENDS_task
-mokogateway
-wifi
= "\
63 kernel-module-ieee80211-crypt \
64 kernel-module-ieee80211-crypt-ccmp \
65 kernel-module-ieee80211-crypt-tkip \
66 kernel-module-ieee80211-crypt-wep \
68 kernel-module-michael-mic \
70 ${@base_contains("COMBINED_FEATURES
", "usbhost
", "kernel
-module
-zd1211rw
", "",d)} \
71 ${@base_contains("COMBINED_FEATURES
", "usbhost
", "zd1211
-firmware
", "",d)} \
74 DESCRIPTION_task
-mokogateway
-debug
= "MokoGateway: Debug"
75 RDEPENDS_task
-mokogateway
-debug
= "\
77 # The following packages are broken
-- victims of libusb confusion.
78 # These packages depend upon libusb
, which provides libusb.a
-- however
79 # everything
else depends upon libusb
-compat
, which also provides libusb.a
80 #
(this includes bluez
-*, usbutils
-*, hal
-*, libhal
-*, etc
). The wrong
81 # libusb.a is staged
for at least somebody. The hacky solution
right now
82 # is
to not build these two utils
, as they are the only ones in common use
83 # that DEPEND upon libusb. This needs
to be fixed in a better way
, but this
84 # will
, at least
, get the feeds working again.
88 # The following packages are obsolete
, and have been replaced.
91 RRECOMMENDS_task
-mokogateway
-debug
= "\