libdmx: Add fso-specs to DEPENDS
[openembedded.git] / recipes / taglib / taglib_1.4.bb
blobe36d952b5b4b9a9dd3b27b596fb63e5a28c145bf
1 DESCRIPTION = "TagLib is a library for reading and editing the meta-data of several popular audio formats"
2 SECTION = "libs/multimedia"
3 HOMEPAGE = "http://developer.kde.org/~wheeler/taglib.html"
4 LICENSE = "LGPL"
5 PR = "r2"
7 SRC_URI = "http://developer.kde.org/~wheeler/files/src/taglib-${PV}.tar.gz \
8 file://taglib_1.4-8.diff.gz;patch=1"
9 S = "${WORKDIR}/taglib-${PV}"
11 inherit autotools pkgconfig binconfig
13 do_postpatch() {
14 rm -rf patches && rm -rf .pc && mv -f debian/patches patches && quilt push -av
16 addtask postpatch after do_patch before do_configure
18 do_stage() {
19 autotools_stage_all
22 PACKAGES =+ "${PN}-c"
23 FILES_${PN}-dbg += "${bindir}/taglib-config"
24 FILES_${PN}-c = "${libdir}/libtag_c.so.*"
26 SRC_URI[md5sum] = "dcd50ddb2544faeae77f194804559404"
27 SRC_URI[sha256sum] = "0ff805bb8dbf72a45d347f2310f7e5c86e2e7419a069d546e53cf5f221c196ab"