libdmx: Add fso-specs to DEPENDS
[openembedded.git] / recipes / sugar / sugar-base_0.84.1.bb
blob34d5bab54fda511d136b6e97f03e2f58a0add5c6
1 DESCRIPTION = "Sugar base system"
2 LICENSE = "LGPLv2"
4 DEPENDS = "python-pygtk sugar-toolkit"
5 RDEPENDS = "librsvg-gtk \
6 gconf \
7 matchbox-wm \
8 ohm-plugin-x11 ohm \
9 hippo-canvas \
10 python-datetime \
11 python-netclient \
12 python-pygtk \
13 sugar-toolkit \
14 python-logging \
15 python-dbus \
16 python-subprocess \
17 telepathy-gabble telepathy-salut telepathy-python \
18 sugar-presence-service \
19 python-pycairo \
20 python-pygobject \
21 python-crypt \
22 python-numpy \
23 python-compression \
24 python-gst \
25 python-simplejson \
26 python-misc \
27 python-xmlrpc \
28 python-compiler \
29 python-pydoc \
30 python-mmap \
31 python-doctest \
32 openssh-keygen"
34 SRC_URI = "http://download.sugarlabs.org/sources/sucrose/glucose/sugar-base/${PN}-${PV}.tar.bz2"
36 inherit autotools distutils-base
38 SRC_URI += "file://acinclude.m4"
40 EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
42 do_configure_prepend() {
43 install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
46 FILES_${PN} += "${datadir}/${PN} \
47 ${datadir}/dbus-1 \
48 ${sysconfdir} "
50 FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/sugar/.debug"
52 AUTOTOOLS_STAGE_PKGCONFIG = "1"
54 do_stage() {
55 autotools_stage_all
59 SRC_URI[md5sum] = "0ef47ff5a8931e0e7c732d22a514d297"
60 SRC_URI[sha256sum] = "e67eab2d058a3410d8fe82a2161d0c268b6445648c5901a8bd2c26690c45addd"