libdmx: Add fso-specs to DEPENDS
[openembedded.git] / recipes / sugar / sugar-base_0.82.2.bb
blob7aae27b269c4a87b321eb36243cd0e1052035c30
1 DESCRIPTION = "Sugar base system"
2 LICENSE = "LGPLv2"
4 PR = "r11"
6 DEPENDS = "python-pygtk sugar-toolkit"
7 RDEPENDS = "librsvg-gtk \
8 ohm-plugin-x11 ohm \
9 hippo-canvas \
10 python-datetime \
11 python-netclient \
12 python-pygtk \
13 sugar-toolkit \
14 python-logging \
15 python-dbus \
16 python-subprocess \
17 telepathy-gabble telepathy-salut telepathy-python \
18 sugar-presence-service \
19 python-crypt \
20 python-numpy \
21 python-compression \
22 python-gst \
23 python-simplejson \
24 python-misc \
25 python-xmlrpc \
26 python-compiler \
27 python-pydoc \
28 python-mmap \
29 python-doctest \
30 ssh-keygen"
32 SRC_URI = "http://dev.laptop.org/pub/sugar/sources/sugar-base/${PN}-${PV}.tar.bz2"
34 inherit autotools distutils-base
36 SRC_URI += "file://acinclude.m4"
38 EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
40 do_configure_prepend() {
41 install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
44 FILES_${PN} += "${datadir}/${PN} \
45 ${datadir}/dbus-1 \
46 ${sysconfdir} "
48 FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/sugar/.debug"
50 AUTOTOOLS_STAGE_PKGCONFIG = "1"
52 do_stage() {
53 autotools_stage_all
57 SRC_URI[md5sum] = "c5790a18fd9ee86a49ffa727505294f5"
58 SRC_URI[sha256sum] = "430b27a0510a50fb66ee211e35565be7e1e522bcde7d1adde5c63a1d18ad7f1d"