libdmx: Add fso-specs to DEPENDS
[openembedded.git] / recipes / phalanx / phalanx_22.bb
blobd368b0736a68968455de74a774b96f32d292bcc6
1 DESCRIPTION = "Phalanx is a chess playing engine."
2 SECTION = "opie/libs"
3 PRIORITY = "optional"
4 PR = "r4"
5 LICENSE = "GPL"
6 SRC_URI = "http://ftp.debian.org/debian/pool/main/p/phalanx/phalanx_22.orig.tar.gz \
7 file://gcc3.patch;patch=1 \
8 file://capabilities \
9 file://description"
10 S = "${WORKDIR}/phalanx-22.orig"
12 do_compile() {
13 oe_runmake CC="${CC}" CFLAGS="${CFLAGS}" STRIP=echo LD="${CC}"
16 do_install() {
17 install -d ${D}${palmtopdir}/chess/engines/Phalanx
18 install -D -m 755 phalanx ${D}${palmtopdir}/chess/engines/Phalanx/phalanx
19 install -D -m 755 pbook.phalanx ${D}${palmtopdir}/chess/engines/Phalanx/pbook.phalanx
20 >${D}${palmtopdir}/chess/engines/Phalanx/sbook.phalanx
21 >${D}${palmtopdir}/chess/engines/Phalanx/learn.phalanx
22 install -D -m 755 ${WORKDIR}/capabilities ${D}${palmtopdir}/chess/engines/Phalanx/capabilities
23 install -D -m 755 ${WORKDIR}/description ${D}${palmtopdir}/chess/engines/Phalanx/description
26 FILES_${PN} = "${palmtopdir}/chess"
27 FILES_${PN}-dbg += "${palmtopdir}/chess/engines/Phalanx/.debug"
29 SRC_URI[md5sum] = "e4e6155530a23ea0ea4ca59f8c5fda8c"
30 SRC_URI[sha256sum] = "e86a0a81ce1b989a4d06e0c07d64e1fcbba2456fa8e22ae24f333f186f3fc663"