libdmx: Add fso-specs to DEPENDS
[openembedded.git] / recipes / ode / ode_0.9.bb
blobe26f32bf8af711e4b22580e48540aab1e2304eaa
1 DESCRIPTION = "ODE is an Open Source Physics Engine."
2 SECTION = "libs"
3 HOMEPAGE = "http://www.ode.org"
4 LICENSE = "LGPL"
5 PR = "r0"
7 SRC_URI = "${SOURCEFORGE_MIRROR}/opende/ode-src-${PV}.zip \
8 file://install.patch;patch=1"
10 inherit autotools binconfig
12 EXTRA_OECONF = "--disable-demos --enable-soname"
14 do_configure_append() {
15 echo "#define dInfinity DBL_MAX" >>include/ode/config.h
18 do_stage() {
19 oe_runmake install \
20 bindir=${STAGING_BINDIR_CROSS} \
21 libdir=${STAGING_LIBDIR} \
22 includedir=${STAGING_INCDIR} \
23 datadir=${STAGING_DATADIR}
26 do_install() {
27 oe_runmake install \
28 bindir=${D}${bindir} \
29 libdir=${D}${libdir} \
30 includedir=${D}${incdir} \
31 datadir=${D}${datadir}
34 FILES_${PN} = "${libdir}/lib*.so*"
36 SRC_URI[md5sum] = "4c03759b76a0649a6d5108c8e172e1e4"
37 SRC_URI[sha256sum] = "460d0851b743b1f144ef2a8259004d6774504c95d08e9357a96a296111496feb"