libdmx: Add fso-specs to DEPENDS
[openembedded.git] / recipes / nylon / nylon-statistics.bb
blobabed00596da5ef9ff0f4f6256e2598b7dbd2fe13
1 DESCRIPTION = "statistics & graphing for nylon"
2 RDEPENDS = "rrdtool"
3 SECTION = "base"
4 PRIORITY = "optional"
5 LICENSE = "GPLv2"
6 #SRCDATE = "20050909"
7 SRCDATE = "20051022"
8 PV = "1.0.0+cvs${SRCDATE}"
9 PR = "r1"
11 SRC_URI = "http://download.berlin.freifunk.net/meshcube.org/nylon/stable/sources/${PN}_gruen.4g__${SRCDATE}.tar.gz"
12 S = "${WORKDIR}/${PN}"
13 PACKAGE_STRIP = "no"
15 do_install() {
16 install -d ${D}/srv/www/cgi-bin
17 install -d ${D}/${sbindir}
18 ln -s /var/tmp ${D}/srv/www/rrd-img
19 install -m 755 ${S}/*.html ${D}/srv/www/cgi-bin
20 ln -s /var/tmp/nav.inc.html ${D}/srv/www/cgi-bin
21 install -m 755 ${S}/collect.sh ${D}/${sbindir}
24 pkg_postinst() {
25 if test "x$D" != "x"; then
26 exit 1
27 else
28 if ! grep -q collect.sh /etc/cron/crontabs/root; then
29 echo "adding crontab"
30 test -d /etc/cron/crontabs || mkdir -p /etc/cron/crontabs
31 echo "*/5 * * * * ${sbindir}/collect.sh" >> /etc/cron/crontabs/root
33 update-rc.d -s busybox-cron defaults
34 /etc/init.d/busybox-cron reload
35 if [ ! -e /etc/httpd.conf ]; then
36 echo "A:*" > /etc/httpd.conf
38 update-rc.d -s busybox-httpd defaults
40 if ! grep -q "/var/lib/rrd/" /etc/nylon/backup.list; then
41 echo "adding to backup list"
42 echo "/var/lib/rrd/" >> /etc/nylon/backup.list
47 FILES_${PN} += "/srv"
49 SRC_URI[md5sum] = "318a328926d72b61e689673b90d53f17"
50 SRC_URI[sha256sum] = "c532fe3a05417cd28d27e81839733d162a133a01bbd1acf8600796351d0a3f8b"