1 DESCRIPTION
= "Japanese input method plugin"
2 HOMEPAGE
= "http://www.sikigami.com/nunome-Qtopia-1.0/"
3 SECTION
= "opie/inputmethods"
6 RDEPENDS
= "virtual-japanese-font"
9 SRC_URI
= "${SOURCEFORGE_MIRROR}/gakusei/nunome-${PV}.tar.bz2 \
10 file://timer.patch;patch=1 \
11 file://nunome.patch;patch=1"
12 S
= "${WORKDIR}/nunome"
16 EXTRA_QMAKEVARS_POST
+= "INCLUDEPATH+=${S}/Nnmlib INCLUDEPATH+=${S}/ui LIBS+=-L${S}"
17 OE_QMAKE_CXXFLAGS
:= "${@oe_filter_out('-fno-rtti', '${OE_QMAKE_CXXFLAGS}', d)}"
20 do_configure_prepend
() {
21 sed
-i
-e 's
,/opt
/QtPalmtop
/bin/,$
{bindir
}/,g'
"${S}/ui/nunome.h"
22 sed
-i
-e 's
,/opt
/QtPalmtop
/,$
{palmtopdir
}/,g'
"${S}/ui/nunome.h"
23 printf
"TEMPLATE=subdirs\nSUBDIRS=Nnmlib server ui dicman ui\n" >nunome.pro
24 cd Nnmlib
&& qmake
-project
-t lib
&& cd ..
/
25 cd server
&& qmake
-project
&& printf
"LIBS+=-lNnmlib\nTARGET=server.bin\n" >> server.pro
&& cd ..
/
26 cd dicman
&& qmake
-project
&& printf
"LIBS+=-lnunome -lNnmlib\nTARGET=dicman.bin\n" >> dicman.pro
&& cd ..
/
27 cd ui
&& qmake
-project
-t lib
&& printf
"LIBS+=-lNnmlib\nTARGET=nunome\n" >> ui.pro
&& cd ..
/
28 find .
-name
"moc*"|xargs rm
-f
29 find .
-name
"Makefile"|xargs rm
-f
33 install
-d $
{D
}$
{palmtopdir
}/lib
34 install
-d $
{D
}$
{bindir
}
35 install
-d $
{D
}$
{palmtopdir
}/i18n
/ja
36 install
-d $
{D
}$
{palmtopdir
}/share
/nunome
38 oe_libinstall
-so libNnmlib $
{D
}$
{palmtopdir
}/lib
39 install
-m
644 nunome_uni.dic $
{D
}$
{palmtopdir
}/share
/nunome
40 install
-m
755 server.
bin $
{D
}$
{bindir
}/nnmsrv
41 install
-m
755 dicman.
bin $
{D
}$
{bindir
}/nnmDicman
42 install
-m
644 ui
/nunome.qm $
{D
}$
{palmtopdir
}/i18n
/ja
43 install
-m
644 dicman
/nnmDicman.qm $
{D
}$
{palmtopdir
}/i18n
/ja
46 SRC_URI
[md5sum
] = "e5c9d2351de250aaa7abf581a1f2c0f4"
47 SRC_URI
[sha256sum
] = "7bda9302036facd65b323d7042a809b08d55d5b61b38d4d40f22f41f27fec83c"