libdmx: Add fso-specs to DEPENDS
[openembedded.git] / recipes / navit / navit-icons_svn.bb
blob5846e651cab6a79ea54f70e38cd2faca55f7132f
1 DESCRIPTION = "Navit is a car navigation system with routing engine."
2 LICENSE = "GPL"
3 SECTION = "x11/applications"
4 DEPENDS = "glib-2.0 gtk+ imagemagick-native librsvg-native"
5 RRECOMMENDS = "gpsd espeak flite"
7 #only icons present in the package
8 PACKAGE_ARCH = "all"
10 PV = "0.1.0+svnr${SRCPV}"
11 PR = "r1"
13 EXTRA_OECONF = "--disable-binding-python --disable-gui-sdl --disable-samplemap --enable-avoid-float --enable-avoid-unaligned --enable-svg2png-scaling-flag=32 --disable-speech-speech-dispatcher"
15 S = "${WORKDIR}/xpm"
17 inherit autotools
19 FILES_${PN} = " /usr/share/navit/xpm/"
21 SRCREV = "3135"
23 #use different URL than navit_svn does, to prevent upgrade/downgrade cycle in downloads dir
24 SRC_URI = "svn://anonymous@navit.svn.sourceforge.net/svnroot/navit/trunk/navit/navit;module=xpm;proto=https \
25 file://configure.in"
27 do_configure_prepend() {
28 cp ${WORKDIR}/configure.in ${S}/
29 # replace include with just xpmdir variable
30 sed -i 's#.*Makefile.inc.*#xpmdir=$(pkgdatadir)/xpm#g' ${S}/Makefile.am
31 # don't install desktopfile and icons
32 sed -i 's/^\(EXTRADIST.*\) $(DESKTOPFILE_DATA) $(ICON128_DATA) $(ICON22_DATA) \(.*\)$/\1\2/g' ${S}/Makefile.am