libdmx: Add fso-specs to DEPENDS
[openembedded.git] / recipes / mc / mc_4.6.2.bb
blob516854b43bbe7c778a3e6936df3b0b99988f84cc
1 require mc.inc
2 PR = "r4"
3 HOMEPAGE = "http://www.midnight-commander.org/"
5 # most of these fixes were copied from openSUSE Factory.
6 SRC_URI = "http://www.midnight-commander.org/downloads/${P}.tar.gz \
7 file://mhl-stdbool.patch;patch=1 \
8 file://mc-utf8.patch;patch=1 \
9 file://00-70-utf8-common.patch;patch=1 \
10 file://00-73-utf8-bottom-buttons-width.patch;patch=1 \
11 file://00-75-utf8-cmdline-help.patch;patch=1 \
12 file://00-76-utf8-hotlist-highlight.patch;patch=1 \
13 file://00-77-utf8-filename-search-highlight.patch;patch=1 \
14 file://mc-utf8-nlink.patch;patch=1 \
15 file://mc-utf8-look-and-feel.patch;patch=1 \
16 file://mc-utf8-slang-codeset.patch;patch=1 \
17 file://99_regexp-replace-fixed.patch;patch=1 \
18 file://99b_fix-regex-pattern-lengths.patch;patch=1 \
19 file://multi-press-f-keys.patch;patch=1 \
20 file://cross-compile.patch;patch=1 \
21 file://01_ftpfs_symlink.patch;patch=1 \
22 file://02_ignore_ftp_chmod_error.patch;patch=1 \
23 file://mc-cursor-appearance.patch;patch=1 \
24 file://mc-esc-seq.patch;patch=1"
26 EXTRA_OECONF = "--without-x --without-samba \
27 --without-nfs --without-gpm-mouse --enable-charset \
28 ac_cv_path_PERL=${bindir}/perl \
29 ac_cv_path_ZIP=${bindir}/zip \
30 ac_cv_path_UNZIP=${bindir}/unzip \
33 do_unpack_append() {
34 bb.build.exec_func('do_utf8_conversion', d)
36 do_utf8_conversion() {
37 pwd
38 pushd lib
39 iconv -f iso8859-1 -t utf-8 -o mc.hint.tmp mc.hint && mv mc.hint.tmp mc.hint
40 iconv -f iso8859-1 -t utf-8 -o mc.hint.es.tmp mc.hint.es && mv mc.hint.es.tmp mc.hint.es
41 iconv -f iso8859-1 -t utf-8 -o mc.hint.it.tmp mc.hint.it && mv mc.hint.it.tmp mc.hint.it
42 iconv -f iso8859-1 -t utf-8 -o mc.hint.nl.tmp mc.hint.nl && mv mc.hint.nl.tmp mc.hint.nl
43 iconv -f iso8859-2 -t utf-8 -o mc.hint.cs.tmp mc.hint.cs && mv mc.hint.cs.tmp mc.hint.cs
44 iconv -f iso8859-2 -t utf-8 -o mc.hint.hu.tmp mc.hint.hu && mv mc.hint.hu.tmp mc.hint.hu
45 iconv -f iso8859-2 -t utf-8 -o mc.hint.pl.tmp mc.hint.pl && mv mc.hint.pl.tmp mc.hint.pl
46 iconv -f iso8859-5 -t utf-8 -o mc.hint.sr.tmp mc.hint.sr && mv mc.hint.sr.tmp mc.hint.sr
47 iconv -f koi8-r -t utf8 -o mc.hint.ru.tmp mc.hint.ru && mv mc.hint.ru.tmp mc.hint.ru
48 iconv -f koi8-u -t utf8 -o mc.hint.uk.tmp mc.hint.uk && mv mc.hint.uk.tmp mc.hint.uk
49 iconv -f big5 -t utf8 -o mc.hint.zh.tmp mc.hint.zh && mv mc.hint.zh.tmp mc.hint.zh
50 iconv -f iso8859-5 -t utf-8 -o mc.menu.sr.tmp mc.menu.sr && mv mc.menu.sr.tmp mc.menu.sr
51 popd
52 # convert docs to utf-8
53 pushd doc
54 pushd es
55 iconv -f iso8859-1 -t utf-8 -o mc.1.in.tmp mc.1.in && mv mc.1.in.tmp mc.1.in
56 iconv -f iso8859-1 -t utf-8 -o xnc.hlp.tmp xnc.hlp && mv xnc.hlp.tmp xnc.hlp
57 popd
58 pushd hu
59 iconv -f iso8859-2 -t utf-8 -o mc.1.in.tmp mc.1.in && mv mc.1.in.tmp mc.1.in
60 iconv -f iso8859-2 -t utf-8 -o xnc.hlp.tmp xnc.hlp && mv xnc.hlp.tmp xnc.hlp
61 popd
62 pushd it
63 iconv -f iso8859-1 -t utf-8 -o mc.1.in.tmp mc.1.in && mv mc.1.in.tmp mc.1.in
64 iconv -f iso8859-1 -t utf-8 -o xnc.hlp.tmp xnc.hlp && mv xnc.hlp.tmp xnc.hlp
65 popd
66 pushd pl
67 iconv -f iso8859-2 -t utf-8 -o mc.1.in.tmp mc.1.in && mv mc.1.in.tmp mc.1.in
68 iconv -f iso8859-2 -t utf-8 -o xnc.hlp.tmp xnc.hlp && mv xnc.hlp.tmp xnc.hlp
69 popd
70 pushd ru
71 iconv -f koi8-r -t utf-8 -o mc.1.in.tmp mc.1.in && mv mc.1.in.tmp mc.1.in
72 iconv -f koi8-r -t utf-8 -o xnc.hlp.tmp xnc.hlp && mv xnc.hlp.tmp xnc.hlp
73 popd
74 pushd sr
75 iconv -f iso8859-5 -t utf-8 -o mc.1.in.tmp mc.1.in && mv mc.1.in.tmp mc.1.in
76 iconv -f iso8859-5 -t utf-8 -o xnc.hlp.tmp xnc.hlp && mv xnc.hlp.tmp xnc.hlp
77 iconv -f iso8859-5 -t utf-8 -o mcserv.8.in.tmp mcserv.8.in && mv mcserv.8.in.tmp mcserv.8.in
78 popd
79 popd
82 do_configure_prepend() {
84 AUTOFOO="config.guess config.sub depcomp install-sh missing mkinstalldirs"
86 for i in ${AUTOFOO}; do
87 rm config/${i}
88 done
91 SRC_URI[md5sum] = "ec92966f4d0c8b50c344fe901859ae2a"
92 SRC_URI[sha256sum] = "d34c913e7fff4ea61cf8640b10f9118829cc5359045a1821b6510f3c8b1be26e"