libdmx: Add fso-specs to DEPENDS
[openembedded.git] / recipes / lockstat / lockstat_1.4.10.bb
blob4f4d7a828631ae056117b85b7ac3517c966fea6e
1 SECTION = "console/utils"
2 DESCRIPTION = "A tool for retrieving kernel spinlock metering information."
3 DEPENDS = "virtual/kernel"
5 SRC_URI = "ftp://oss.sgi.com/projects/lockmeter/download/old/lockstat-${PV}.tar.gz"
6 S = "${WORKDIR}/lockstat"
8 SRC_URI[md5sum] = "924779ede0615f41d033dc8eb49361fd"
9 SRC_URI[sha256sum] = "43125a2f26db5254bef8063bd85cfda60f32cbbc8ddb4d4141294d5d3627bf61"
11 export KERNEL_VERSION = "${@base_read_file('${STAGING_KERNEL_DIR}/kernel-abiversion')}"
12 export KERNEL_SOURCE = "${@base_read_file('${STAGING_KERNEL_DIR}/kernel-source')}"
13 CFLAGS += " -I${KERNEL_SOURCE}/include"
15 python () {
16 # NOTE: any target machines with kernels supporting spinlock metering should
17 # check the MACHINE variable here to prevent the SkipPackage.
18 raise bb.parse.SkipPackage("The target machine's kernel does not appear able to use spinlock metering.")
21 do_compile () {
22 oe_runmake
25 do_install () {
26 install -d ${D}${sbindir}
27 install -m 0755 lockstat ${D}${sbindir}/