libdmx: Add fso-specs to DEPENDS
[openembedded.git] / recipes / linux / linux_2.6.26.bb
blob6089f47bf5a5f79d66d14185f277dd8671ae9358
1 require linux.inc
3 PR = "r10"
5 # Mark archs/machines that this kernel supports
6 DEFAULT_PREFERENCE = "-1"
7 DEFAULT_PREFERENCE_boc01 = "1"
8 DEFAULT_PREFERENCE_mpc8313e-rdb = "1"
9 DEFAULT_PREFERENCE_canyonlands = "1"
10 DEFAULT_PREFERENCE_topas910 = "1"
13 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.26.tar.bz2;name=kernel \
14 ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${PV}.8.bz2;patch=1;name=stablepatch \
15 file://defconfig"
17 SRC_URI_append_boc01 = "\
18 file://boc01.dts \
19 file://fsl-elbc-nand-backport.patch;patch=1 \
20 file://002-081105-headers.patch;patch=1 \
21 file://004-081105-usb.patch;patch=1 \
22 file://005-081217-isl12024.patch;patch=1 \
23 file://006-081216-at24c32.patch;patch=1 \
24 file://007-081216-lm73.patch;patch=1 \
25 file://008-081127-spi.patch;patch=1 \
26 file://010-081105-mii.patch;patch=1 \
27 file://011-081202-gpio.patch;patch=1 \
28 file://012-081222-cy3218-btns.patch;patch=1 \
29 file://013-081212-lcd.patch;patch=1 \
32 SRC_URI_append_mpc8313e-rdb = "\
33 file://cdc-ether-hack.patch;patch=1 \
34 file://fsl-elbc-nand-backport.patch;patch=1 \
35 file://mpc8313e-rdb-leds.patch;patch=1 \
36 file://mpc8313e-rdb-cardbus.patch;patch=1 \
37 file://mpc8313e-rdb-eth-fixed.patch;patch=1 \
40 SRC_URI_append_topas910 = "http://www.bplan-gmbh.org/data/toshiba/topas/linux/2.6.26.5/patch_2.6.26.5_topas910.bz2;patch=1;name=topaspatch"
42 # see http://bugzilla.kernel.org/show_bug.cgi?id=11143
43 do_install_append() {
44 if [ -f arch/${ARCH}/lib/crtsavres.o ]; then
45 mkdir -p $kerneldir/arch/${ARCH}/lib
46 cp -a arch/${ARCH}/lib/crtsavres.o $kerneldir/arch/${ARCH}/lib/
51 SRC_URI[kernel.md5sum] = "5169d01c405bc3f866c59338e217968c"
52 SRC_URI[kernel.sha256sum] = "666488e2511393fdb901eaf1e67275bcc38ab37c930e8a9adb290a95c1721a2a"
53 SRC_URI[stablepatch.md5sum] = "e27c07bb82e02532e874758980141281"
54 SRC_URI[stablepatch.sha256sum] = "611f7e118b5b09898493eab4c3071771742f2f3826b5733fa2f47284a38fbcf3"
56 SRC_URI[topaspatch.md5sum] = "092957fc9e029010106c4fa59ef2c098"
57 SRC_URI[topaspatch.sha256sum] = "eefecb157633d2be256c0f6a2d46ab764027bbb906cf5c250be67b95e80767bb"