3 # Mark archs
/machines that this kernel supports
4 DEFAULT_PREFERENCE
= "-1"
5 DEFAULT_PREFERENCE_mpc8313e
-rdb
= "1"
6 DEFAULT_PREFERENCE_mpc8323e
-rdb
= "1"
7 DEFAULT_PREFERENCE_avr32
= "1"
11 SRC_URI
= "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.23.tar.bz2;name=kernel \
12 file://binutils-buildid-arm.patch;patch=1 \
13 file://kallsyms-missing-include.patch;patch=1 \
17 # Bug fixes on the
2.6.23.x stable branch
18 SRC_URI
+= "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-2.6.23.17.bz2;patch=1;name=stablepatch"
19 # Real
-time preemption
(includes CFS
). This is experimental
and requires a different defconfig.
20 #SRC_URI
+= "file://patch-2.6.23.12-rt14;patch=1"
21 # Only the Completely Fair Scheduler
(CFS
), the official backport from
2.6.24 (adapted
for 2.6.23.17)
22 SRC_URI
+= "file://sched-cfs-v2.6.23.12-v24.1.patch;patch=1"
23 # Add support
for squashfs
-lzma
(a highly compressed
read-only filesystem
)
24 SRC_URI
+= "http://kamikaze.waninkoko.info/patches/2.6.23/klight1/broken-out/squashfs-lzma-2.6.23.patch;patch=1;name=squashfspatch"
26 SRC_URI
+= "file://time.h.patch;patch=1"
28 # The Atmel patch doesn't apply against
2.6.23.12 :(
29 SRC_URI_avr32
= "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.23.tar.bz2;name=kernel \
31 http://avr32linux.org/twiki/pub/Main/LinuxPatches/linux-2.6.23.atmel.3.patch.bz2;patch=1;name=atmelpatch \
33 SRC_URI_append_em
-x270
= "\
34 file://em-x270.patch;patch=1 "
36 SRC_URI_append_cm
-x270
= "\
37 file://0001-cm-x270-base2.patch;patch=1 \
38 file://0002-cm-x270-match-type.patch;patch=1 \
39 file://0003-cm-x270-ide.patch;patch=1 \
40 file://0004-cm-x270-it8152.patch;patch=1 \
41 file://0005-cm-x270-pcmcia.patch;patch=1 \
42 file://0006-ramdisk_load.patch;patch=1 \
43 file://0007-mmcsd_large_cards-r0.patch;patch=1 \
44 file://0008-cm-x270-nand-simplify-name.patch;patch=1"
46 SRC_URI_append_mpc8313e
-rdb
= "\
47 file://mpc831x-nand.patch;patch=1 \
48 file://mpc8313e-rdb-leds.patch;patch=1 \
49 file://mpc8313e-rdb-rtc.patch;patch=1"
51 SRC_URI_append_mpc8323e
-rdb
= "\
52 file://mpc832x-leds.patch;patch=1"
54 CMDLINE_cm
-x270
= "console=${CMX270_CONSOLE_SERIAL_PORT},38400 monitor=8 bpp=16 mem=64M mtdparts=physmap-flash.0:256k(boot)ro,0x180000(kernel),-(root);cm-x270-nand:64m(app),-(data) rdinit=/sbin/init root=mtd3 rootfstype=jffs2"
56 FILES_kernel
-image_cm
-x270
= ""
58 python do_compulab_image
() {
63 machine
= bb.
data.getVar
('MACHINE'
, d
, 1)
64 if machine
== "cm-x270":
65 deploy_dir
= bb.
data.getVar
('DEPLOY_DIR_IMAGE'
, d
, 1)
66 kernel_file
= os.path.join
(deploy_dir
, bb.
data.expand
('$
{KERNEL_IMAGE_BASE_NAME
}'
, d
) + '.
bin'
)
67 img_file
= os.path.join
(deploy_dir
, bb.
data.expand
('$
{KERNEL_IMAGE_BASE_NAME
}'
, d
) + '.cmx270'
)
69 fo
= open
(img_file
, 'wb'
)
71 image_data
= open
(kernel_file
, 'rb'
).
read()
73 #
first write size into
first 4 bytes
74 size_s
= struct.pack
('i'
, len(image_data
))
76 # truncate size
if we are running on a
64-bit host
84 link_file
= bb.
data.expand
('$
{KERNEL_IMAGE_SYMLINK_NAME
}'
, d
) + '.cmx270'
85 img_file
= bb.
data.expand
('$
{KERNEL_IMAGE_BASE_NAME
}'
, d
) + '.cmx270'
90 os.symlink
(img_file
, link_file
)
94 addtask compulab_image
after do_package
before do_build
97 SRC_URI
[kernel.md5sum
] = "2cc2fd4d521dc5d7cfce0d8a9d1b3472"
98 SRC_URI
[kernel.sha256sum
] = "d4e67c0935ffb2a4158234bff92cc791b83177866009fc9b2214104e0038dbdb"
99 SRC_URI
[stablepatch.md5sum
] = "7d2dbdf18868b496548d4375d8c67d3a"
100 SRC_URI
[stablepatch.sha256sum
] = "04dfd3f22dc3abce7d7509c0836350540b60cadd19292be70a2a2900c5fbe7b8"
101 SRC_URI
[squashfspatch.md5sum
] = "4f9b572c2381c457d866cda9300208de"
102 SRC_URI
[squashfspatch.sha256sum
] = "e0f476d04af5921d4a44ab312a03fc6c7122b71adff6e38add8aa188d9969784"
103 SRC_URI
[atmelpatch.md5sum
] = "649a8c56f8c5cc2c8deee0055f7ed5b0"
104 SRC_URI
[atmelpatch.sha256sum
] = "80de5fe71259921fcd4dd3182f58791ec6eb8380e6030fac10c1d2a53a10133e"