3 # Mark archs
/machines that this kernel supports
4 DEFAULT_PREFERENCE
= "-1"
5 DEFAULT_PREFERENCE_cm
-x270
= "-1"
6 DEFAULT_PREFERENCE_bd
-neon
= "0"
7 DEFAULT_PREFERENCE_mx31moboard
= "1"
11 SRC_URI
= "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.22.tar.bz2;name=kernel \
12 ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${PV}.19.bz2;patch=1;name=stablepatch \
16 SRC_URI_append_cm
-x270
= "\
17 file://0001-cm-x270-base2.patch;patch=1 \
18 file://0002-cm-x270-match-type.patch;patch=1 \
19 file://0003-cm-x270-ide.patch;patch=1 \
20 file://0004-cm-x270-it8152.patch;patch=1 \
21 file://0005-cm-x270-pcmcia.patch;patch=1 \
22 file://0006-ramdisk_load.patch;patch=1 \
23 file://0007-mmcsd_large_cards-r0.patch;patch=1 \
24 file://0008-cm-x270-nand-simplify-name.patch;patch=1"
26 SRC_URI_append_mx31moboard
= "http://mobots.epfl.ch/mx31moboard/linux-2.6.22-moboard.patch.bz2;patch=1;name=mx31patch"
28 CMDLINE_cm
-x270
= "console=${CMX270_CONSOLE_SERIAL_PORT},38400 monitor=8 bpp=16 mem=64M mtdparts=physmap-flash.0:256k(boot)ro,0x180000(kernel),-(root);cm-x270-nand:64m(app),-(data) rdinit=/sbin/init root=mtd3 rootfstype=jffs2"
30 FILES_kernel
-image_cm
-x270
= ""
32 SRC_URI_append_bd
-neon
= " http://www.boundarydevices.com/boundary-2.6.22-2007-07-22.patch.bz2;patch=1;name=neonpatch"
34 python do_compulab_image
() {
39 machine
= bb.
data.getVar
('MACHINE'
, d
, 1)
40 if machine
== "cm-x270":
41 deploy_dir
= bb.
data.getVar
('DEPLOY_DIR_IMAGE'
, d
, 1)
42 kernel_file
= os.path.join
(deploy_dir
, bb.
data.expand
('$
{KERNEL_IMAGE_BASE_NAME
}'
, d
) + '.
bin'
)
43 img_file
= os.path.join
(deploy_dir
, bb.
data.expand
('$
{KERNEL_IMAGE_BASE_NAME
}'
, d
) + '.cmx270'
)
45 fo
= open
(img_file
, 'wb'
)
47 image_data
= open
(kernel_file
, 'rb'
).
read()
49 #
first write size into
first 4 bytes
50 size_s
= struct.pack
('i'
, len(image_data
))
52 # truncate size
if we are running on a
64-bit host
60 link_file
= bb.
data.expand
('$
{KERNEL_IMAGE_SYMLINK_NAME
}'
, d
) + '.cmx270'
61 img_file
= bb.
data.expand
('$
{KERNEL_IMAGE_BASE_NAME
}'
, d
) + '.cmx270'
66 os.symlink
(img_file
, link_file
)
69 addtask compulab_image
after do_deploy
before do_build
71 SRC_URI
[kernel.md5sum
] = "2e230d005c002fb3d38a3ca07c0200d0"
72 SRC_URI
[kernel.sha256sum
] = "73c10604c53f1a6ee65ef805293d23903696f8cef864f42d7de9506f0d2ba4c7"
73 SRC_URI
[stablepatch.md5sum
] = "066cc3bdd2783dcd01f6ff466e449ec0"
74 SRC_URI
[stablepatch.sha256sum
] = "829c48b49c71d89468f2a5a05587714811197545eeba31e9643cabacf344d33a"
76 SRC_URI
[neonpatch.md5sum
] = "7dac7a5cf401070ecccf42666a30fc0a"
77 SRC_URI
[neonpatch.sha256sum
] = "da8a360035464defd133a4ba604aa7ae9ee077747511b98384862b4cbdde5906"