libdmx: Add fso-specs to DEPENDS
[openembedded.git] / recipes / linux / linux-x86_2.6.20.bb
blobb63078099620537adb4006cfbe3eae1a05367d57
1 DESCRIPTION = "Linux Kernel for x86 compatible machines"
2 SECTION = "kernel"
3 LICENSE = "GPLv2"
4 PR = "r5"
6 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 "
8 SRC_URI_append_x86 = "file://i486-defconfig"
9 SRC_URI_append_i586 = "file://i586-defconfig"
10 SRC_URI_append_i686 = "file://i686-defconfig"
12 S = "${WORKDIR}/linux-${PV}"
14 KERNEL_IMAGETYPE ?= "bzImage"
16 inherit kernel
18 COMPATIBLE_HOST = "i.86.*-linux"
20 do_configure_prepend_x86() {
21 install -m 0644 ${WORKDIR}/i486-defconfig ${S}/.config
24 do_configure_prepend_i586-generic() {
25 install -m 0644 ${WORKDIR}/i586-defconfig ${S}/.config
28 do_configure_prepend_i686() {
29 install -m 0644 ${WORKDIR}/i686-defconfig ${S}/.config
32 SRC_URI[md5sum] = "34b0f354819217e6a345f48ebbd8f13e"
33 SRC_URI[sha256sum] = "2c14ada1ac7d272e03b430d3a530d60fc9ec69cc8252382aa049afba7d2b8558"