2 DESCRIPTION
= "Linux kernel for the Linksys WRT54 devices"
6 SRC_URI
= "${KERNELORG_MIRROR}/pub/linux/kernel/v2.4/linux-2.4.20.tar.bz2 \
7 file://linux-2.4.20-mipscvs.patch;patch=1 \
8 file://2.4.20_broadcom_3_37_2_1109_US.patch;patch=1 \
9 file://110-sch_htb.patch;patch=1 \
10 file://120-openwrt.patch;patch=1 \
11 file://130-nfsswap.patch;patch=1 \
12 file://140-ebtables-brnf-5.patch;patch=1 \
13 file://150-mppe-mppc-0.98.patch;patch=1 \
14 file://160-expr.patch;patch=1 \
15 file://linux-2.4.24-attribute-used.patch;patch=1 \
16 file://gcc_mtune.patch;patch=1 \
17 file://gcc3.patch;patch=1 \
18 file://nobcom.patch;patch=1 \
19 file://compressed-20040531.tar.bz2 \
22 S
= "${WORKDIR}/linux-2.4.20"
25 COMPATIBLE_HOST
= 'mipsel.
*-linux'
29 CMDLINE_CONSOLE ?
= "ttyS0,115200n8"
30 CMDLINE_ROOT ?
= "root=/dev/mtdblock2 noinitrd"
31 # CMDLINE_INIT
= "init=/bin/busybox ash"
33 CMDLINE
= "${CMDLINE_ROOT} ${CMDLINE_CONSOLE} ${CMDLINE_INIT}"
34 EXTRA_OEMAKE
+= "'SRCBASE=${STAGING_LIBDIR}/bcom'"
37 install
-m
0644 $
{WORKDIR
}/diag.c $
{S
}/drivers
/net
/diag
/diag_led.c
38 if [ -e $
{WORKDIR
}/compressed
]; then
39 rm
-rf $
{S
}/arch
/mips
/brcm
-boards
/bcm947xx
/compressed
40 mv $
{WORKDIR
}/compressed $
{S
}/arch
/mips
/brcm
-boards
/bcm947xx
/compressed
43 addtask unpack_extra
after do_patch
before do_configure
45 do_configure_prepend
() {
46 install
-m
0644 $
{WORKDIR
}/defconfig $
{S
}/.config
47 echo
"CONFIG_CMDLINE=\"${CMDLINE}\"" >> $
{S
}/.config
50 COMPATIBLE_MACHINE
= "wrt54"
52 SRC_URI
[md5sum
] = "c439d5c93d7fc9a1480a90842465bb97"
53 SRC_URI
[sha256sum
] = "8c08d562e2263ac82cb47a7b6fcb8e2c1a6cb33d598fa92b0731351f26620875"