libdmx: Add fso-specs to DEPENDS
[openembedded.git] / recipes / linux / linux-titan-sh4_2.6.21.bb
blob9f60f2013ef8fe5e9bd1e726b738f8d2efb55337
1 SECTION = "kernel"
2 DESCRIPTION = "Linux kernel for SH4 based TITAN (NP51R/LinkGear Series 100) router appliance"
3 LICENSE = "GPLv2"
4 PR = "r2"
6 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
7 file://titan-flash.patch;patch=1 \
8 file://titan-pcibios-scan-update.patch;patch=1 \
9 file://no-mm-mutex.patch;patch=1 \
10 file://linux-2.6-limits.patch;patch=1 \
11 file://linux-sh-__sdivsi3_i4i.patch;patch=1 \
12 file://titan-config"
13 S = "${WORKDIR}/linux-${PV}"
15 COMPATIBLE_HOST = 'sh4.*-linux'
16 COMPATIBLE_MACHINE = "titan"
18 inherit kernel
20 ARCH = "sh"
21 KERNEL_OUTPUT = "arch/${ARCH}/boot/${KERNEL_IMAGETYPE}"
24 # Use an updated defconfig which includes the flash driver
25 # The flash driver quality doesn't allow it to be a part of the main kernel
27 do_configure_prepend() {
28 install -m 0644 ${WORKDIR}/titan-config ${S}/arch/sh/configs/titan_defconfig
29 yes '' | oe_runmake titan_defconfig
32 SRC_URI[md5sum] = "1b515f588078dfa7f4bab2634bd17e80"
33 SRC_URI[sha256sum] = "f187b12d70e0a48ce81f0472dfe9504fb5f0f966be339ac9d57dd2b991a74942"