1 DESCRIPTION
= "Linux Kernel for smdk2443 compatible machines"
4 DEPENDS
+= "u-boot-mkimage-openmoko-native"
8 GGSRC
= "http://www.xora.org.uk/oe/patches/"
10 SRC_URI
= "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git;protocol=git;tag=v2.6.21-rc5 \
11 file://0020-Add-ASoC-S3C24xx-platform-support.patch;patch=1 \
12 file://0021-Add-Neo1973-ASoC-support.patch;patch=1 \
13 file://0022-Add-initial-ASoC-SMDK2440-support.patch;patch=1 \
14 file://0023-Add-ASoC-SMDK2440-support-for-WM8956-codec.patch;patch=1 \
15 file://0034-Export-ac97_dai.patch;patch=1 \
16 file://0036-Move-s3c24xx_i2s_dai-and-add-dma_size.patch;patch=1 \
17 file://0037-Use-dma_size-parameter-and-fix-buffdone-oops.patch;patch=1 \
18 file://0038-Add-smdk2443-s3c2443-ac97-and-wm9710-support.patch;patch=1 \
19 file://asoc-mainline.patch;patch=1 \
20 file://defconfig-smdk2443"
26 COMPATIBLE_HOST
= "arm.*-linux"
27 COMPATIBLE_MACHINE
= "smdk2443"
30 install $
{WORKDIR
}/defconfig
-smdk2443 $
{S
}/.config
35 $
{OBJCOPY
} -O binary
-R .note
-R .comment
-S vmlinux linux.
bin
38 uboot
-mkimage
-A arm
-O linux
-T kernel
-C gzip
-a
30008000 -e
30008000 -n
"smdk2443 kernel" -d linux.
bin.gz $
{DEPLOY_DIR_IMAGE
}/uImage
-$
{PV
}-$
{MACHINE
}-$
{DATETIME
}.
bin
42 KERNEL_RELEASE
= "2.6.21-rc5"