libdmx: Add fso-specs to DEPENDS
[openembedded.git] / recipes / linux / linux-sequoia_2.6.21.bb
blob35b74fafc995a3a9ab451e9bfb85c6bc2380f71d
1 # Copyright (C) 2007, Stelios Koroneos - Digital OPSiS, All Rights Reserved
2 # Released under the MIT license (see packages/COPYING)
3 SECTION = "kernel"
4 DESCRIPTION = "Linux kernel for AMCC's Sequoia dev board"
5 LICENSE = "GPLv2"
6 PR = "r0"
7 #DEPENDS = "u-boot"
9 COMPATIBLE_MACHINE = "sequoia"
11 #DENX git kernel
12 #Same as in AMCC's sequoia dev kit
13 SRC_URI ="git://www.denx.de/git/linux-2.6-denx.git;protocol=git;tag=78157a82fa20719f7e3307307755888e9af2c0e9 \
14 file://sequoia_defconfig "
17 S = "${WORKDIR}/git"
19 inherit kernel
21 export ARCH="ppc"
23 KERNEL_IMAGETYPE = "zImage.elf"
25 do_configure() {
26 install -m 644 ${WORKDIR}/sequoia_defconfig ${S}/.config
27 make ARCH=${ARCH} oldconfig
30 do_install_append () {
31 #need ppc platforms includes + friends in order for external kernel modules to compile as headers a$
33 install -d $kerneldir/arch/
34 cp -pPR arch/ppc $kerneldir/arch/
35 cp -pPR arch/powerpc $kerneldir/arch/
37 install -d $kerneldir/include/asm
38 cp -pPR include/asm-powerpc $kerneldir/include/
39 cp -pPR include/asm-ppc $kerneldir/include/
42 #seems like 2.6.21 kernel images have moved (or is this only for the Denx kernel ?)
43 #so we need to copy the kernel image where kernel.bbclass expects it to be
44 do_install_prepend() {
45 install -m 0644 arch/${ARCH}/boot/images/${KERNEL_IMAGETYPE} \
46 arch/${ARCH}/boot/${KERNEL_IMAGETYPE}