libdmx: Add fso-specs to DEPENDS
[openembedded.git] / recipes / linux / linux-palmpre_2.6.24.bb
blobb21eed375acb8b49ed59dc449b064e5cfe9ca7fd
1 require linux.inc
3 DESCRIPTION = "Linux kernel for Palm Pre. Original version of Palm, Inc."
4 KERNEL_IMAGETYPE = "uImage"
6 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2;name=kernel \
7 http://palm.cdnetworks.net/opensource/1.1.0/linux-2.6.24-patch.gz;patch=1;name=patch \
10 S = "${WORKDIR}/linux-2.6.24"
12 # We try to build the identical kernel as Palms here, use their defconfig.
13 do_configure_prepend() {
14 install -m 0644 ${S}/arch/arm/configs/omap_sirloin_3430_defconfig ${WORKDIR}/defconfig
17 # linux.inc overrides LOCAVERSION but we like to stay with the one used originally
18 do_compile_prepend() {
19 sed -i -e '/CONFIG_LOCALVERSION=/d' ${S}/.config
20 echo 'CONFIG_LOCALVERSION="-joplin-3430"' >>${S}/.config
23 SRC_URI[kernel.md5sum] = "3f23ad4b69d0a552042d1ed0f4399857"
24 SRC_URI[kernel.sha256sum] = "413c64fbbcf81244cb5571be4963644a1e81166a2b0f008a016528363b65c5d3"
25 SRC_URI[patch.md5sum] = "1c5547aa497a7eae9fa52ed4df4b0f11"
26 SRC_URI[patch.sha256sum] = "5f7c232f9216ce45f0ab0045098cd2b21b6f2f8a7668bffd2e06040a5b87ba84"