libdmx: Add fso-specs to DEPENDS
[openembedded.git] / recipes / linux / linux-omap-psp_2.6.32.bb
blob77545d82da5f7884a915cd592da50b8834d2f916
1 require multi-kernel.inc
3 DESCRIPTION = "Linux kernel for OMAP processors"
4 KERNEL_IMAGETYPE = "uImage"
6 COMPATIBLE_MACHINE = "beagleboard|omap3evm|am3517-evm|dm3730-am3715-evm|omap3-touchbook|overo"
8 # This is the v2.6.32_OMAPPSP_03.00.00.05 branch
9 SRCREV = "dc94d8db03fc6c5918960ebf069cfc81e5998665"
11 # The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc
12 MACHINE_KERNEL_PR_append = "+gitr${SRCREV}"
14 SRC_URI = "git://arago-project.org/git/people/sriram/ti-psp-omap.git;protocol=git;branch=master \
15 file://0001-Revert-omap3-beagle-Fix-compile-time-errors.patch;patch=1 \
16 file://0002-board-omap3touchbook-make-it-build-against-TI-linux-.patch;patch=1 \
17 file://0003-ARM-OMAP-add-support-for-TCT-Zippy-to-Beagle-board-f.patch;patch=1 \
18 file://0004-ARM-OMAP-Make-beagle-u-boot-partition-writable.patch;patch=1 \
19 file://0005-board-omap3-beagle-add-DSS2-support.patch;patch=1 \
20 file://0006-beagleboard-omap3_-foo-_rate_table-omap35x_-foo-_rat.patch;patch=1 \
21 file://0007-board-omap3beagle-prepare-for-DM3730-based-Beagleboa.patch;patch=1 \
22 file://0008-mt9t111-first-stab-at-merging-sensor-driver-based-on.patch;patch=1 \
23 file://0009-board-omap3beagle-ugly-copy-paste-job-to-get-mt9p111.patch;patch=1 \
24 file://0010-board-omap3beagle-turn-on-power-to-camera-on-boot-an.patch;patch=1 \
25 file://0011-board-omap3beagle-update-omap34xxcam-to-more-recent-.patch;patch=1 \
26 file://0012-ASoC-enable-audio-capture-by-default-for-twl4030.patch;patch=1 \
27 file://0013-MTD-NAND-omap2-proper-fix-for-subpage-read-ECC-error.patch;patch=1 \
28 file://0014-OMAP3630-DSS2-Enable-Pre-Multiplied-Alpha-Support.patch;patch=1 \
29 file://0015-DSS2-add-bootarg-for-selecting-svideo-or-composite-f.patch;patch=1 \
30 file://0016-ISP-add-some-more-from-Leopard-imaging-patch.patch;patch=1 \
31 file://0017-ARM-OMAP-Overo-Add-support-for-second-ethernet-port.patch;patch=1 \
32 file://0018-drivers-net-smsc911x-return-ENODEV-if-device-is-not-.patch;patch=1 \
33 file://0019-drivers-input-touchscreen-ads7846-return-ENODEV-if-d.patch;patch=1 \
34 file://0020-drivers-mfd-add-twl4030-madc-driver.patch;patch=1 \
35 file://0021-ARM-OMAP-Add-missing-twl4030-madc-header-file.patch;patch=1 \
36 file://0022-ARM-OMAP-Add-twl4030-madc-support-to-Overo.patch;patch=1 \
37 file://0023-ARM-OMAP-Add-twl4030-madc-support-to-Beagle.patch;patch=1 \
38 file://0024-netdev-rt73usb-add-vendor-device-ID-for-Ceiva-Wirele.patch;patch=1 \
39 file://0025-mmc-don-t-display-single-block-read-console-messages.patch;patch=1 \
40 file://0026-ARM-OMAP2-mmc-twl4030-move-clock-input-selection-pri.patch;patch=1 \
41 file://0027-board-overo-add-PM-code-and-sync-with-http-www.sakom.patch;patch=1 \
42 file://0028-twl4030-madc-adjust-for-twl4030-twl-api-changes.patch;patch=1 \
43 file://0029-OMAP-DSS2-Re-add-support-for-Samsung-lte430wq-f0c-pa.patch;patch=1 \
44 file://0030-OMAP-DSS2-Add-support-for-LG-Philips-LB035Q02-panel.patch;patch=1 \
45 file://0031-Fix-for-bus-width-which-improves-SD-card-s-peformanc.patch;patch=1 \
46 file://0032-ARM-VFP-add-support-to-sync-the-VFP-state-of-the-cur.patch;patch=1 \
47 file://0033-ARM-VFP-preserve-the-HW-context-when-calling-signal-.patch;patch=1 \
48 file://0034-Switch-SGX-clocks-to-200MHz-on-DM37xx-OMAP36xx.patch;patch=1 \
49 file://0035-modedb.c-add-proper-720p60-mode.patch;patch=1 \
50 file://0036-RTC-add-support-for-backup-battery-recharge.patch;patch=1 \
51 file://0037-ARM-Add-prompt-for-CONFIG_ALIGNMENT_TRAP.patch;patch=1 \
52 file://0038-ARM-Print-warning-on-alignment-trap-in-kernel-mode.patch;patch=1 \
53 file://0039-ARM-Expose-some-CPU-control-registers-via-sysfs.patch;patch=1 \
54 file://0040-ARM-Add-option-to-allow-userspace-PLE-access.patch;patch=1 \
55 file://0041-ARM-Add-option-to-allow-userspace-access-to-performa.patch;patch=1 \
56 file://0042-ARM-Expose-some-PMON-registers-through-sysfs.patch;patch=1 \
57 file://0043-musb-allow-host-io-without-gadget-module.patch;patch=1 \
58 file://0044-MTD-silence-ecc-errors-on-mtdblock0.patch;patch=1 \
59 file://0045-ARM-OMAP-update-beagleboard-defconfig.patch;patch=1 \
60 file://defconfig"
62 SRC_URI_append_beagleboard = " file://logo_linux_clut224.ppm \
65 SRC_URI_append_omap3-touchbook = " \
66 file://0001-ARM-OMAP-add-spi-platform-devices.patch;patch=1 \
67 file://0002-MMA7455L-accelerometer-driver.patch;patch=1 \
68 file://0003-bq27x00_battery-remove-error-message-output.patch;patch=1 \
69 file://0004-bq27x00_battery-add-charged-gpio.patch;patch=1 \
70 file://0005-adf7846-add-more-debugging.patch;patch=1 \
71 file://0006-ads7846-read-max-mix-x-y-from-pdata.patch;patch=1 \
72 file://0007-ads7846-add-settling-delay-to-pdata.patch;patch=1 \
73 file://0008-DSS2-OMAPFB-Translate-X-Y-coordinates-for-the-video-.patch;patch=1 \
74 file://0009-DSS2-fix-rotation-offsets.patch;patch=1 \
75 file://0010-DSS2-Fix-scaling-checks-when-rotation-is-90-or-270-d.patch;patch=1 \
76 file://0011-add-touchbook-hid-driver.patch;patch=1 \
77 file://0012-Make-backlight-controls-accessible-to-users.patch;patch=1 \
78 file://0013-ads7846-don-t-error-out-when-there-s-no-pendown-gpio.patch;patch=1 \
79 file://0014-ASoC-add-driver-for-omap3-touchbook.patch;patch=1 \
80 file://0015-backlight-add-PWM-support.patch;patch=1 \
81 file://0016-ARM-OMAP-omap3-touchbook-update-boardfile.patch;patch=1 \
84 addtask quiltfixup before do_patch after do_unpack
85 do_quiltfixup() {
86 rm ${S}/.pc -rf
89 S = "${WORKDIR}/git"
91 do_install_append() {
92 install -d ${D}/boot
93 install -m 0644 Documentation/arm/OMAP/DSS ${D}/boot/
96 PACKAGES =+ "omap-dss-doc"
97 FILES_omap-dss-doc = "/boot/DSS"