1 DESCRIPTION
= "Linux kernel for MTX-3 (Surfbox3)"
2 HOMEPAGE
= "http://meshcube.org/meshwiki/"
6 inherit module
-base kernel
8 PROVIDES
= "virtual/kernel"
11 SRC_URI
+= "cvs://cvs:cvs@ftp.linux-mips.org/home/cvs;module=linux;tag=linux_2_6_15 \
12 file://defconfig-mtx-3"
14 FILESDIR
= "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/linux-mtx-3-${PV}"
16 S
= "${WORKDIR}/linux"
20 COMPATIBLE_MACHINE
= "mtx-3"
21 COMPATIBLE_HOST
= "arm.*-linux"
23 KERNEL_OUTPUT
= "arch/arm/zboot/images/mtx-3.flash.bin"
24 KERNEL_IMAGETYPE
= "zImage.flash"
25 KERNEL_IMAGEDEST
= "tmp"
27 KERNEL_IMAGE_NAME
= "kernel-${KV}-${MACHINE}_${BUILDNAME}"
29 MTX_KERNEL_NON_PCI_OHCI
= "no"
31 PACKAGE_ARCH
= "mtx-3"
33 do_configure_prepend
() {
34 install
-m
0644 $
{WORKDIR
}/defconfig
-mtx
-3 $
{S
}/.config
35 if [ "x${MTX_KERNEL_NON_PCI_OHCI}" == "xyes" ]; then
36 echo
"CONFIG_USB_NON_PCI_OHCI=y" >> $
{S
}/.config
40 pkg_postinst_kernel
() {
41 if test
"x$D" != "x"; then
44 if test
-e
/tmp
/zImage.flash
-$
{KV
}; then
45 echo
"*** flashing kernel ***"
46 flashcp
-v
/tmp
/zImage.flash
-$
{KV
} /dev
/mtd
/2
47 echo
"*** done. please reboot ***"
52 FILES_kernel
+= " /tmp"
55 install
-d $
{DEPLOY_DIR
}/images
56 install
-m
0644 arch
/arm
/zboot
/images
/mtx
-3.flash.
bin $
{DEPLOY_DIR
}/images
/$
{KERNEL_IMAGE_NAME
}.flash.
bin
57 install
-m
0644 arch
/arm
/zboot
/images
/mtx
-3.flash.srec $
{DEPLOY_DIR
}/images
/$
{KERNEL_IMAGE_NAME
}.flash.srec
58 install
-m
0644 arch
/arm
/zboot
/images
/mtx
-3.srec $
{DEPLOY_DIR
}/images
/$
{KERNEL_IMAGE_NAME
}.ram.srec