libdmx: Add fso-specs to DEPENDS
[openembedded.git] / recipes / linux / linux-efika_2.6.20.20.bb
blob972677b07206ba609c1240e2cc0cbe054f2d02f2
1 DESCRIPTION = "Linux Kernel for the EFIKA dev platform"
2 SECTION = "kernel"
3 LICENSE = "GPLv2"
4 PR = "r2"
6 COMPATIBLE_MACHINE = "efika"
8 FILESPATH = "${FILE_DIRNAME}/linux-efika-${PV}:${FILE_DIRNAME}/linux-efika-2.6.20"
10 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.20.tar.bz2;name=kernel \
11 file://0001-powerpc-serial-Dispose-irq-mapping-when-done-in-mpc52xx_serial.c.txt;p=1;patch=1 \
12 file://0003-powerpc-Add-device-tree-fixups-for-the-EFIKA.txt;p=1;patch=1 \
13 file://0004-powerpc-Use-common-52xx-of_platform-probe-code-for-EFIKA.txt;p=1;patch=1 \
14 file://0005-powerpc-Restore-proper-link-order-in-platform.txt;p=1;patch=1 \
15 file://0006-Rework-the-OHCI-quirk-mecanism-as-suggested-by-David.txt;p=1;patch=1 \
16 file://0007-Implement-support-for-split-endian-OHCI.txt;p=1;patch=1 \
17 file://0008-ohci-Rework-bus-glue-integration-to-allow-several-at-once.txt;p=1;patch=1 \
18 file://0009-ohci-Add-support-for-OHCI-controller-on-the-of_platform-bus.txt;p=1;patch=1 \
19 file://0010-libata-Add-support-for-the-MPC52xx-ATA-controller.txt;p=1;patch=1 \
20 file://0011-ohci-Whitespace-and-typo-fix-in-ohci-ppc-of.c.txt;p=1;patch=1 \
21 file://0012-ata-Fix-pata_mpc52xx.c-compatible-list.txt;p=1;patch=1 \
22 file://0013-powerpc-serial-Fix-mpc52xx_uart.c-compatible-list.txt;p=1;patch=1 \
23 file://0014-powerpc-Small-cleanup-of-EFIKA-platform.txt;p=1;patch=1 \
24 file://0015-powerpc-Add-a-unified-uevent-handler-for-bus-based-on-of_device.txt;p=1;patch=1 \
25 file://0016-macintosh-Use-the-new-of_device-common-uevent-handler.txt;p=1;patch=1 \
26 file://0017-powerpc-Add-uevent-handler-for-of_platform_bus.txt;p=1;patch=1 \
27 file://0018-powerpc-Add-uevent-handler-for-ibmebus.txt;p=1;patch=1 \
28 file://0019-MPC5200-Bestcomm-platform-driver.txt;p=1;patch=1 \
29 file://0020-Fec-MPC5200-eth-driver.txt;p=1;patch=1 \
30 file://0021-POWERPC-Copy-bestcomm-support-files-into-arch-powerpc.txt;p=1;patch=1 \
31 file://0022-MPC52xx-PCI-now-working-on-lite5200.-ugly-but-working.txt;p=1;patch=1 \
32 file://0023-POWERPC-Make-FEC-work-on-the-lite5200.txt;p=1;patch=1 \
33 file://0024-Add-missing-function-prototype.txt;p=1;patch=1 \
34 file://0025-POWERPC-Misc-EFIKA-fixups-for-rtas-chrp.txt;p=1;patch=1 \
35 file://0026-POWERPC-Cleanup-mpc52xx-PCI-support.txt;p=1;patch=1 \
36 file://0027-POWERPC-Change-name-of-mpc52xx-pci-support-file-in-Makefile.txt;p=1;patch=1 \
37 file://0028-POWERPC-Change-link-order-so-mpc52xx-fec-always-shows-up-as-eth0.txt;p=1;patch=1 \
38 file://0029-POWERPC-Fixup-pr_print-format-for-mpc52xx-pci-support.txt;p=1;patch=1 \
39 file://0030-POWERPC-Add-mpc52xx-lite5200-PCI-support.txt;p=1;patch=1 \
40 file://0031-sound-Add-support-for-the-MPC52xx-PSC-AC97-Link.txt;p=1;patch=1 \
41 file://0032-POWERPC-EFIKA-Adds-missing-interrupts-from-bestcomm-node.txt;p=1;patch=1 \
42 file://0033-EFIKA-fullduplex-prpl_aln.txt;p=1;patch=1 \
43 file://v4l.diff;p=1;patch=1 \
44 http://www.kernel.org/pub/linux/kernel/v2.6/patch-2.6.20.20.bz2;p=1;patch=1;name=stablepatch \
45 http://people.redhat.com/mingo/cfs-scheduler/sched-cfs-v2.6.20.20-v22.patch;p=1;patch=1;name=shedpatch \
46 file://weaken-div64_32-symbol.patch;patch=1 \
47 file://defconfig \
50 S = "${WORKDIR}/linux-2.6.20"
52 inherit kernel
54 export ARCH="powerpc"
57 do_configure() {
58 install -m 644 ${WORKDIR}/defconfig ${S}/.config
59 make ARCH=${ARCH} oldconfig
62 do_install_append () {
63 #need ppc platforms includes + friends in order for external kernel modules to compile as headers as still split
65 install -d $kerneldir/arch/
66 cp -pPR arch/ppc $kerneldir/arch/
67 cp -pPR arch/powerpc $kerneldir/arch/
69 install -d $kerneldir/include/asm
70 cp -pPR include/asm-powerpc $kerneldir/include/
71 cp -pPR include/asm-ppc $kerneldir/include/
74 SRC_URI[kernel.md5sum] = "34b0f354819217e6a345f48ebbd8f13e"
75 SRC_URI[kernel.sha256sum] = "2c14ada1ac7d272e03b430d3a530d60fc9ec69cc8252382aa049afba7d2b8558"
76 SRC_URI[stablepatch.md5sum] = "08b2c1e9759ca409a0d2ca49db1bbedb"
77 SRC_URI[stablepatch.sha256sum] = "0417fc3609f5746bce6016862e7f83e83e98e17e5ae77887bf66b37748ab261c"
78 SRC_URI[shedpatch.md5sum] = "0fd84a82c51f67d2d0531aab78f66d2a"
79 SRC_URI[shedpatch.sha256sum] = "fc5cd165ecc07d2e254412f39a17a26a753bf081a0e02ed5db0b02d2f6bacc6f"