1 DESCRIPTION
= "Linux kernel for bug"
3 PV_append
= "+svnr${SRCREV}"
7 COMPATIBLE_MACHINE
= "bug"
9 SVN_PRJ
= "bug-linux-${KV}"
12 SRC_URI
= "svn://svn.buglabs.net/bug/branches/R1.4/qa;module=${SVN_PRJ};proto=svn \
16 S
= "${WORKDIR}/${SVN_PRJ}"
19 UBOOT_ENTRYPOINT
= "0x80008000"
24 cd $
{D
}/$
{KERNEL_IMAGEDEST
} && ln
-sf uImage
-$
{KERNEL_VERSION
} uImage
28 cp
-fR arch
/arm
/include/asm
/* $kerneldir
/include/asm
/
29 if [ ! -e $kerneldir
/include/mach
]; then
30 mkdir $kerneldir
/include/mach
32 cp
-fR arch
/arm
/plat
-mxc
/include/mach
/* $kerneldir
/include/mach
/
35 FILESDIR
= "${WORKDIR}"
36 FILES_kernel
-image
+= "${KERNEL_IMAGEDEST}/uImage*"
38 module_conf_g_ether
= "options g_ether host_addr=46:0d:9e:67:69:eb"
39 module_conf_bmi_audio
= "options bmi_audio output_ints=1"
40 module_autoload_arcotg_udc
= "arcotg_udc"
41 module_autoload_ehci
-hcd
= "ehci-hcd"
42 module_autoload_g_ether
= "g_ether"
43 module_autoload_bugnav
= "bugnav"
44 module_autoload_bug_audio
= "bug_audio"
45 module_autoload_bugpm
= "bugpm"
46 module_autoload_bugpm_apm
= "bugpm_apm"
47 module_autoload_rtc
-isl12026
= "rtc-isl12026"
48 module_autoload_bug_v4l2_capture
= "bug_v4l2_capture"
49 module_autoload_libertas_sdio
= "libertas_sdio"
50 # bmi_lcd_core loaded
to ensure xserver device nodes are created on boot.
51 module_autoload_bmi_lcd_core
= "bmi_lcd_core"