libdmx: Add fso-specs to DEPENDS
[openembedded.git] / recipes / libgcrypt / libgcrypt_1.1.91.bb
blobd0ca4acf121a99ae8b67ad55a2347881ff29c42a
1 PR = "r3"
2 DESCRIPTION = "A general purpose cryptographic library based on the code from GnuPG"
3 SECTION = "libs"
4 PRIORITY = "optional"
5 LICENSE = "GPL LGPL FDL"
6 DEPENDS = "libgpg-error"
8 PACKAGES =+ "libgcrypt-pthread libgcrypt-pthread-dev"
10 # move libgcrypt-config into -dev package
11 FILES_${PN} = "${libdir}/lib*.so.*"
12 FILES_${PN}-dev += "${bindir}"
13 FILES_libgcrypt-pthread = "${libdir}/libgcrypt-pthread.so.*"
14 FILES_libgcrypt-pthread-dev = "${libdir}/libgcrypt-pthread.*"
16 SRC_URI = "ftp://ftp.gnupg.org/gcrypt/alpha/libgcrypt/libgcrypt-${PV}.tar.gz"
18 inherit autotools binconfig
20 EXTRA_OECONF = "--without-pth"
22 do_stage() {
23 oe_libinstall -so -C src libgcrypt ${STAGING_LIBDIR}
24 oe_libinstall -so -C src libgcrypt-pthread ${STAGING_LIBDIR}
25 install -m 0755 src/libgcrypt-config ${STAGING_BINDIR_CROSS}/
27 install -d ${STAGING_INCDIR}/
28 for X in gcrypt.h gcrypt-module.h
30 install -m 0644 src/${X} ${STAGING_INCDIR}/${X}
31 done
35 SRC_URI[md5sum] = "8f3581d2d2a66c8f42b16f6ce13dedc3"
36 SRC_URI[sha256sum] = "9ea092029d2b32dc5eb06b38494dcc264d1a46835296ac1ed0433fff25030b83"