libdmx: Add fso-specs to DEPENDS
[openembedded.git] / recipes / ifupdown / ifupdown-ubuntu_0.6.8.bb
blob3c8de81a107e8364b6ed15b663f72ec8b263baff
1 DESCRIPTION = "High level tools to configure network interfaces \
2 This package provides the tools ifup and ifdown which may be used to \
3 configure (or, respectively, deconfigure) network interfaces, based on \
4 the file /etc/network/interfaces."
5 LICENSE = "GPL"
7 SECTION = "base"
9 PROVIDES = "ifupdown"
11 PR = "r2"
13 inherit update-rc.d
15 SRC_URI = "http://archive.ubuntu.com/ubuntu/pool/main/i/ifupdown/ifupdown_0.6.8ubuntu19.tar.gz;name=ifupdown \
16 file://init"
18 SRC_URI[ifupdown.md5sum] = "9c4533a289bd55316a9981b1fe41fad4"
19 SRC_URI[ifupdown.sha256sum] = "4c86cc0534061896c1f825766a29fe5282607123b8978b623f5c6f1fa5458b4d"
21 EXTRA_OEMAKE = ""
23 S = "${WORKDIR}/ifupdown-${PV}ubuntu15"
25 do_compile () {
26 chmod a+rx *.pl *.sh
27 oe_runmake 'CC=${CC}' "CFLAGS=${CFLAGS} -Wall -W -D'IFUPDOWN_VERSION=\"${PV}\"'"
30 do_install () {
31 install -d ${D}${sysconfdir}/init.d \
32 ${D}${sysconfdir}/network \
33 ${D}${mandir}/man8 \
34 ${D}${mandir}/man5 \
35 ${D}${base_sbindir}
36 install -m 0755 ifup ${D}${base_sbindir}/
37 ln ${D}${base_sbindir}/ifup ${D}${base_sbindir}/ifdown
38 install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/ifup
39 install -m 0644 ifup.8 ${D}${mandir}/man8
40 install -m 0644 interfaces.5 ${D}${mandir}/man5
41 cd ${D}${mandir}/man8 && ln -s ifup.8 ifdown.8
43 INITSCRIPT_NAME = "ifup"
44 INITSCRIPT_PARAMS = "start 39 S . stop 39 0 6 1 ."