3 SRC_URI_append_virtclass
-native
= " file://no-demos.patch;patch=1 \
6 SRC_URI
[gtk.md5sum
] = "5517f78b1eb9b1eb60bd48a0152d09e6"
7 SRC_URI
[gtk.sha256sum
] = "8ea7e11ff88e9a8867b7d9221d40a3bfce5c648ce27cd6bac422ff8f6cca414d"
11 BBCLASSEXTEND
= "native"
13 DEPENDS_virtclass
-native
= "libpng-native atk-native pango-native cairo-native libxrender-native libxext-native"
14 RRECOMMENDS_$
{PN
}_virtclass
-native
= ""
15 PROVIDES_virtclass
-native
= "gdk-pixbuf-csource-native"
17 # Enable xkb selectively
18 XKBTOGGLE
= " --disable-xkb"
19 XKBTOGGLE_angstrom
= ""
21 EXTRA_OECONF
= "--with-libtiff ${XKBTOGGLE} --disable-glibtest gio_can_sniff=yes"
22 EXTRA_OECONF_append_virtclass
-native
= " --without-libtiff --without-libjpeg"
24 PACKAGES_DYNAMIC
= "gtk-module-* gdk-pixbuf-loader-* gtk-immodule-* gtk-printbackend-*"
26 python populate_packages_prepend
() {
29 prologue
= bb.
data.getVar
("postinst_prologue", d
, 1)
31 gtk_libdir
= bb.
data.expand
('$
{libdir
}/gtk
-2.0/$
{LIBV
}'
, d
)
32 loaders_root
= os.path.join
(gtk_libdir
, 'loaders'
)
33 immodules_root
= os.path.join
(gtk_libdir
, 'immodules'
)
34 printmodules_root
= os.path.join
(gtk_libdir
, 'printbackends'
);
35 modules_root
= bb.
data.expand
('$
{libdir
}/gtk
-2.0/modules
/'
,d
)
37 do_split_packages
(d
, loaders_root
, '^libpixbufloader
-(.
*)\.so$'
, 'gdk
-pixbuf
-loader
-%s'
, 'GDK pixbuf loader
for %s'
, prologue
+ 'gdk
-pixbuf
-query
-loaders
> /etc
/gtk
-2.0/gdk
-pixbuf.loaders'
, extra_depends
=''
)
38 do_split_packages
(d
, immodules_root
, '^im
-(.
*)\.so$'
, 'gtk
-immodule
-%s'
, 'GTK
input module
for %s'
, prologue
+ 'gtk
-query
-immodules
-2.0 > /etc
/gtk
-2.0/gtk.immodules'
, extra_depends
=''
)
39 do_split_packages
(d
, printmodules_root
, '^libprintbackend
-(.
*)\.so$'
, 'gtk
-printbackend
-%s'
, 'GTK printbackend module
for %s'
, extra_depends
=''
)
40 do_split_packages
(d
, modules_root
, '^lib
(.
*)\.so$'
, 'gtk
-module
-%s'
, 'GTK module
for %s'
, extra_depends
=''
)
42 if (bb.
data.getVar
('DEBIAN_NAMES'
, d
, 1)):
43 bb.
data.setVar
('PKG_$
{PN
}'
, 'libgtk
-2.0'
, d
)
46 # gail is part of gtk
+ since gtk
+-2.13.0 (targetting
>=GNOME
2.23):
47 PROVIDES
= "virtual/gail"
48 RPROVIDES_$
{PN
} = "libgailutil18"
49 RCONFLICTS_$
{PN
} = "libgailutil18"
50 RREPLACES_$
{PN
} = "libgailutil18"
51 RPROVIDES_$
{PN
}-dev
= "libgailutil-dev"
52 RCONFLICTS_$
{PN
}-dev
= "libgailutil-dev"
53 RREPLACES_$
{PN
}-dev
= "libgailutil-dev"
54 RPROVIDES_$
{PN
}-doc
= "libgailutil-doc"
55 RCONFLICTS_$
{PN
}-doc
= "libgailutil-doc"
56 RREPLACES_$
{PN
}-doc
= "libgailutil-doc"
57 RPROVIDES_$
{PN
}-dbg
= "libgailutil-dbg"
58 RCONFLICTS_$
{PN
}-dbg
= "libgailutil-dbg"
59 RREPLACES_$
{PN
}-dbg
= "libgailutil-dbg"
60 # FIXME
: replace locales as well