5 # Enable xkb selectively
6 XKBTOGGLE
= " --disable-xkb"
7 XKBTOGGLE_angstrom
= ""
9 EXTRA_OECONF
= "--with-libtiff ${XKBTOGGLE} --disable-glibtest gio_can_sniff=yes"
11 PACKAGES_DYNAMIC
= "gtk-module-* gdk-pixbuf-loader-* gtk-immodule-* gtk-printbackend-*"
13 python populate_packages_prepend
() {
16 prologue
= bb.
data.getVar
("postinst_prologue", d
, 1)
18 gtk_libdir
= bb.
data.expand
('$
{libdir
}/gtk
-2.0/$
{LIBV
}'
, d
)
19 loaders_root
= os.path.join
(gtk_libdir
, 'loaders'
)
20 immodules_root
= os.path.join
(gtk_libdir
, 'immodules'
)
21 printmodules_root
= os.path.join
(gtk_libdir
, 'printbackends'
);
22 modules_root
= bb.
data.expand
('$
{libdir
}/gtk
-2.0/modules
/'
,d
)
24 do_split_packages
(d
, loaders_root
, '^libpixbufloader
-(.
*)\.so$'
, 'gdk
-pixbuf
-loader
-%s'
, 'GDK pixbuf loader
for %s'
, prologue
+ 'gdk
-pixbuf
-query
-loaders
> /etc
/gtk
-2.0/gdk
-pixbuf.loaders'
, extra_depends
=''
)
25 do_split_packages
(d
, immodules_root
, '^im
-(.
*)\.so$'
, 'gtk
-immodule
-%s'
, 'GTK
input module
for %s'
, prologue
+ 'gtk
-query
-immodules
-2.0 > /etc
/gtk
-2.0/gtk.immodules'
, extra_depends
=''
)
26 do_split_packages
(d
, printmodules_root
, '^libprintbackend
-(.
*)\.so$'
, 'gtk
-printbackend
-%s'
, 'GTK printbackend module
for %s'
, extra_depends
=''
)
27 do_split_packages
(d
, modules_root
, '^lib
(.
*)\.so$'
, 'gtk
-module
-%s'
, 'GTK module
for %s'
, extra_depends
=''
)
29 if (bb.
data.getVar
('DEBIAN_NAMES'
, d
, 1)):
30 bb.
data.setVar
('PKG_$
{PN
}'
, 'libgtk
-2.0'
, d
)
33 # gail is part of gtk
+ since gtk
+-2.13.0 (targetting
>=GNOME
2.23):
34 PROVIDES
= "virtual/gail"
35 RPROVIDES_$
{PN
} = "libgailutil18"
36 RCONFLICTS_$
{PN
} = "libgailutil18"
37 RREPLACES_$
{PN
} = "libgailutil18"
38 RPROVIDES_$
{PN
}-dev
= "libgailutil-dev"
39 RCONFLICTS_$
{PN
}-dev
= "libgailutil-dev"
40 RREPLACES_$
{PN
}-dev
= "libgailutil-dev"
41 RPROVIDES_$
{PN
}-doc
= "libgailutil-doc"
42 RCONFLICTS_$
{PN
}-doc
= "libgailutil-doc"
43 RREPLACES_$
{PN
}-doc
= "libgailutil-doc"
44 RPROVIDES_$
{PN
}-dbg
= "libgailutil-dbg"
45 RCONFLICTS_$
{PN
}-dbg
= "libgailutil-dbg"
46 RREPLACES_$
{PN
}-dbg
= "libgailutil-dbg"
47 # FIXME
: replace locales as well
50 SRC_URI
[gtk.md5sum
] = "369e173600efc272131b53b1902679e8"
51 SRC_URI
[gtk.sha256sum
] = "1c0665fe560a560851e8b3c9a6501d416c4b54abfb6fa07549d703a04ea768bf"