5 SRC_URI
+= "file://smallscreen_filechooser.patch;patch=1 \
8 EXTRA_OECONF
= "--with-libtiff --disable-xkb --disable-glibtest --enable-display-migration gio_can_sniff=yes"
10 PACKAGES_DYNAMIC
= "gtk-module-* gdk-pixbuf-loader-* gtk-immodule-* gtk-printbackend-*"
12 python populate_packages_prepend
() {
15 prologue
= bb.
data.getVar
("postinst_prologue", d
, 1)
17 gtk_libdir
= bb.
data.expand
('$
{libdir
}/gtk
-2.0/$
{LIBV
}'
, d
)
18 loaders_root
= os.path.join
(gtk_libdir
, 'loaders'
)
19 immodules_root
= os.path.join
(gtk_libdir
, 'immodules'
)
20 printmodules_root
= os.path.join
(gtk_libdir
, 'printbackends'
);
21 modules_root
= bb.
data.expand
('$
{libdir
}/gtk
-2.0/modules
/'
,d
)
23 do_split_packages
(d
, loaders_root
, '^libpixbufloader
-(.
*)\.so$'
, 'gdk
-pixbuf
-loader
-%s'
, 'GDK pixbuf loader
for %s'
, prologue
+ 'gdk
-pixbuf
-query
-loaders
> /etc
/gtk
-2.0/gdk
-pixbuf.loaders'
, extra_depends
=''
)
24 do_split_packages
(d
, immodules_root
, '^im
-(.
*)\.so$'
, 'gtk
-immodule
-%s'
, 'GTK
input module
for %s'
, prologue
+ 'gtk
-query
-immodules
-2.0 > /etc
/gtk
-2.0/gtk.immodules'
, extra_depends
=''
)
25 do_split_packages
(d
, printmodules_root
, '^libprintbackend
-(.
*)\.so$'
, 'gtk
-printbackend
-%s'
, 'GTK printbackend module
for %s'
, extra_depends
=''
)
26 do_split_packages
(d
, modules_root
, '^lib
(.
*)\.so$'
, 'gtk
-module
-%s'
, 'GTK module
for %s'
, extra_depends
=''
)
28 if (bb.
data.getVar
('DEBIAN_NAMES'
, d
, 1)):
29 bb.
data.setVar
('PKG_$
{PN
}'
, 'libgtk
-2.0'
, d
)
32 # gail is part of gtk
+ since gtk
+-2.13.0 (targetting
>=GNOME
2.23):
33 PROVIDES
= "virtual/gail"
34 RPROVIDES_$
{PN
} = "libgailutil18"
35 RCONFLICTS_$
{PN
} = "libgailutil18"
36 RREPLACES_$
{PN
} = "libgailutil18"
37 RPROVIDES_$
{PN
}-dev
= "libgailutil-dev"
38 RCONFLICTS_$
{PN
}-dev
= "libgailutil-dev"
39 RREPLACES_$
{PN
}-dev
= "libgailutil-dev"
40 RPROVIDES_$
{PN
}-doc
= "libgailutil-doc"
41 RCONFLICTS_$
{PN
}-doc
= "libgailutil-doc"
42 RREPLACES_$
{PN
}-doc
= "libgailutil-doc"
43 RPROVIDES_$
{PN
}-dbg
= "libgailutil-dbg"
44 RCONFLICTS_$
{PN
}-dbg
= "libgailutil-dbg"
45 RREPLACES_$
{PN
}-dbg
= "libgailutil-dbg"
46 # FIXME
: replace locales as well
48 SRC_URI
[gtk.md5sum
] = "b693a2c1c2dd95457b87d0d042aa5bba"
49 SRC_URI
[gtk.sha256sum
] = "efc277e87e3b7e0315eb3c2837fad6a06aab92b38e08fec6f30beb53e7e56e09"