2 DESCRIPTION
= "GTK+1.2 is a deprecated library provided for running programs not yet converted to GTK+2.0"
3 HOMEPAGE
= "http://www.gtk.org"
6 DEPENDS
= "glib-1.2 jpeg libpng libxext"
9 SRC_URI
= "ftp://ftp.gtk.org/pub/gtk/v1.2/gtk+-${PV}.tar.gz \
10 file://timezone-fix.patch;patch=1 \
11 file://gtk+1.2-reconf-fix;patch=1 \
12 file://no-xwc;patch=1"
13 S
= "${WORKDIR}/gtk+-${PV}"
15 inherit autotools pkgconfig flow
-lossage
17 do_configure_prepend
() {
19 rm
-f ltconfig libtool ltmain.sh aclocal.m4
20 sed
-i
-e s
:AM_LC_MESSAGES
:gt_LC_MESSAGES
:g acinclude.m4
23 FILES_$
{PN
} += "${datadir}/themes"
24 FILES_$
{PN
}-dev
+= "${datadir}/gtk-1.2/include ${libdir}/gtk-1.2/include"
27 EXTRA_OECONF
= "--enable-debug=no --disable-glibtest --disable-xim"
32 gtk_include
= "fnmatch.h gtk.h gtkaccelgroup.h gtkaccellabel.h gtkadjustment.h gtkalignment.h gtkarg.h gtkarrow.h gtkaspectframe.h gtkbbox.h gtkbin.h gtkbindings.h gtkbox.h gtkbutton.h gtkcalendar.h gtkcheckbutton.h gtkcheckmenuitem.h gtkclist.h gtkcolorsel.h gtkcombo.h gtkcompat.h gtkcontainer.h gtkctree.h gtkcurve.h gtkdata.h gtkdebug.h gtkdialog.h gtkdnd.h gtkdrawingarea.h gtkeditable.h gtkentry.h gtkenums.h gtkeventbox.h gtkfeatures.h gtkfilesel.h gtkfixed.h gtkfontsel.h gtkframe.h gtkgamma.h gtkgc.h gtkhandlebox.h gtkhbbox.h gtkhbox.h gtkhpaned.h gtkhruler.h gtkhscale.h gtkhscrollbar.h gtkhseparator.h gtkimage.h gtkinputdialog.h gtkintl.h gtkinvisible.h gtkitem.h gtkitemfactory.h gtklabel.h gtklayout.h gtklist.h gtklistitem.h gtkmain.h gtkmarshal.h gtkmenu.h gtkmenubar.h gtkmenufactory.h gtkmenuitem.h gtkmenushell.h gtkmisc.h gtknotebook.h gtkobject.h gtkoptionmenu.h gtkpacker.h gtkpaned.h gtkpixmap.h gtkplug.h gtkpreview.h gtkprivate.h gtkprogress.h gtkprogressbar.h gtkradiobutton.h gtkradiomenuitem.h gtkrange.h gtkrc.h gtkruler.h gtkscale.h gtkscrollbar.h gtkscrolledwindow.h gtkselection.h gtkseparator.h gtksignal.h gtksocket.h gtkspinbutton.h gtkstatusbar.h gtkstyle.h gtktable.h gtktearoffmenuitem.h gtktext.h gtkthemes.h gtktipsquery.h gtktogglebutton.h gtktoolbar.h gtktooltips.h gtktree.h gtktreeitem.h gtktypebuiltins.h gtktypeutils.h gtkvbbox.h gtkvbox.h gtkviewport.h gtkvpaned.h gtkvruler.h gtkvscale.h gtkvscrollbar.h gtkvseparator.h gtkwidget.h gtkwindow.h makeenums.h stamp-gtkmarshal.h stamp-gtktypebuiltins.h"
33 gdk_include
= "MwmUtil.h gdk.h gdkcursors.h gdki18n.h gdkinput.h gdkinputcommon.h gdkinputgxi.h gdkinputnone.h gdkinputxfree.h gdkkeysyms.h gdkprivate.h gdkrgb.h gdktypes.h gdkx.h gxid_lib.h gxid_proto.h"
36 oe_libinstall
-so
-C gtk libgtk $
{STAGING_LIBDIR
}
37 oe_libinstall
-so
-C gdk libgdk $
{STAGING_LIBDIR
}
39 mkdir
-p $
{STAGING_INCDIR
}/gtk
-1.2/gtk
40 for i in $
{gtk_include
}; do
41 install
-m
0644 gtk
/$i $
{STAGING_INCDIR
}/gtk
-1.2/gtk
/$i
44 mkdir
-p $
{STAGING_INCDIR
}/gtk
-1.2/gdk
45 for i in $
{gdk_include
}; do
46 install
-m
0644 gdk
/$i $
{STAGING_INCDIR
}/gtk
-1.2/gdk
/$i
49 mkdir
-p $
{STAGING_LIBDIR
}/gtk
-1.2/include
51 install
-m
0644 gtk.m4 $
{STAGING_DATADIR
}/aclocal
/
52 install
-m
0755 gtk
-config $
{STAGING_BINDIR_CROSS
}/
55 do_install_append
() {
56 install
-d $
{D
}$
{sysconfdir
}/gtk
-1.2
60 SRC_URI
[md5sum
] = "4d5cb2fc7fb7830e4af9747a36bfce20"
61 SRC_URI
[sha256sum
] = "3fb843ea671c89b909fd145fa09fd2276af3312e58cbab29ed1c93b462108c34"