libdmx: Add fso-specs to DEPENDS
[openembedded.git] / recipes / gtk+ / gdk-pixbuf_2.10.14.bb
blob1ff2687bf0bb56c59f4b50abc48806565ab9dc02
1 DESCRIPTION = "Stand-alone libpixbuf, a pixelmap image i/o library from the \
2 GTK+ multi-platform toolkit for creating graphical user interfaces."
3 HOMEPAGE = "http://www.gtk.org/"
4 SECTION = "libs"
5 LICENSE = "LGPL"
6 PRIORITY = "optional"
7 DEPENDS = "libpng gettext glib-2.0"
8 PR = "r2"
10 S = "${WORKDIR}/gtk+-${PV}"
11 FILESPATH = "${FILE_DIRNAME}/gdk-pixbuf-csource:${FILE_DIRNAME}/gtk+-${PV}:${FILE_DIRNAME}/files"
13 SRC_URI = "\
14 ftp://ftp.gtk.org/pub/gtk/v2.10/gtk+-${PV}.tar.bz2 \
15 file://automake-lossage.patch;patch=1 \
18 inherit autotools pkgconfig
20 LIBV = "2.10.0"
22 FILES_${PN} = "${bindir}/gdk-pixbuf-query-loaders \
23 ${bindir}/gtk-update-icon-cache \
24 ${libdir}/lib*.so.*"
26 FILES_${PN}-dev += " \
27 ${datadir}/gtk-2.0/include \
28 ${libdir}/gtk-2.0/include \
29 ${libdir}/gtk-2.0/${LIBV}/loaders/*.la \
30 ${bindir}/gdk-pixbuf-csource \
31 ${bindir}/gtk-builder-convert"
33 FILES_${PN}-dbg += " \
34 ${libdir}/gtk-2.0/${LIBV}/loaders/.debug/*"
36 EXTRA_OECONF = "\
37 --without-x \
38 --with-gdktarget=linux-fb \
39 --without-libtiff \
40 --without-libjpeg \
41 --with-libpng \
44 EXTRA_OECONF += "--disable-modules --with-included-loaders=png,tga"
46 # check for TARGET_FPU=soft and inform configure of the result so it can disable some floating points
47 require gtk-fpu.inc
48 EXTRA_OECONF += "${@get_gtk_fpu_setting(bb, d)}"
50 do_compile() {
51 cd gdk-pixbuf && oe_runmake
54 do_stage() {
55 oe_libinstall -C gdk-pixbuf -so libgdk_pixbuf-2.0 ${STAGING_LIBDIR}
56 cd gdk-pixbuf && oe_runmake install DESTDIR=${STAGING_DIR_HOST}${layout_exec_prefix}
57 autotools_stage_includes
58 # install -d -m 0755 ${STAGING_LIBDIR}/gtk-2.0/include
59 # install -m 0644 gdk/gdkconfig.h ${STAGING_LIBDIR}/gtk-2.0/include/gdkconfig.h
62 do_install() {
63 oe_libinstall -C gdk-pixbuf -so libgdk_pixbuf-2.0 ${D}/${libdir}
64 cd gdk-pixbuf && oe_runmake install DESTDIR=${D}
68 SRC_URI[md5sum] = "018d7dd0fa7de01cfdb77c7c55e7ba26"
69 SRC_URI[sha256sum] = "d02344239d048390ba02fcfd7de4f9efc0dfb51e7b06dfa46a6314d666ea4de2"