libdmx: Add fso-specs to DEPENDS
[openembedded.git] / recipes / gs / gs_8.64.bb
blob20171cab3416baa52835e6bf1c0fdaa619e00e75
1 DESCRIPTION = "An interpreter of the Postscript language"
2 LICENSE = "GPL"
3 SECTION = "console/utils"
4 HOMEPAGE = "http://www.gnu.org/software/ghostscript/ghostscript.html"
5 DEPENDS = "jpeg zlib fontconfig cups"
6 PR = "r2"
8 SRC_URI = "${DEBIAN_MIRROR}/main/g/ghostscript/ghostscript_${PV}~dfsg.orig.tar.gz;name=tarball \
9 file://0001_svn_snapshot.patch;patch=1 \
10 file://0002_svn_snapshot_jbig2dec.patch;patch=1 \
11 file://1001_install_cjk_examples.patch;patch=1 \
12 file://1002_ps2pdf_man_fix.patch;patch=1 \
13 file://1003_fix_autoconf_create_from_infiles.patch;patch=1 \
14 file://1004_CVE-2009-0792_CVE-2009-0584_CVE-2009-0583.patch;patch=1 \
15 file://1006_system-jasper.patch;patch=1 \
16 file://1007_fix_pphs_script_not_lib.patch;patch=1 \
17 file://2001_docdir_fix_for_debian.patch;patch=1 \
18 file://2002_gs_man_fix_debian.patch;patch=1 \
21 SRC_URI[tarball.md5sum] = "e42706c2409815df5c959484080fd4a3"
22 SRC_URI[tarball.sha256sum] = "cc856d33cb781cdc3383b8eb4e0f390997f8359fe144a906b84297b5d377f03d"
25 S = "${WORKDIR}/ghostscript-${PV}~dfsg"
27 inherit autotools
29 EXTRA_OECONF = "--without-x --with-jasper --with-zlib=${STAGING_DIR_HOST}${layout_prefix}"
31 TARGET_CC_ARCH += "${LDFLAGS}"
33 PACKAGES += "cups-gs"
35 do_configure() {
36 # hack script to allow for cross compiling
37 sed 's,&& ./configure$,& --host=\$host --build=\$build --target=\$target,g' -i configure
39 gnu-configize
40 oe_runconf
43 do_stage () {
44 install -d ${STAGING_INCDIR}/ghostscript
45 install -m 755 ${S}/psi/*.h ${STAGING_INCDIR}/ghostscript/
46 oe_libinstall -so -C sobin libgs ${STAGING_LIBDIR}
49 do_compile_append () {
50 oe_runmake so
53 do_install_append () {
54 oe_runmake 'DESTDIR=${D}' soinstall
57 FILES_${PN} += "${datadir}/ghostscript"
58 FILES_cups-gs = "${libdir}/cups/filter/* ${datadir}/cups ${sysconfdir}/cups"
60 RDEPENDS_cups-gs += "gs"