libdmx: Add fso-specs to DEPENDS
[openembedded.git] / recipes / gpephone / gpe-session-scripts-phone_0.67.bb
blob296dec0278d7cd634fdaa13ffab38141eb524ee7
1 inherit gpe
3 DESCRIPTION = "GPE session startup scripts hack for GPE Phone Edition"
4 LICENSE = "GPL"
5 SECTION = "gpe"
6 PRIORITY = "optional"
7 RDEPENDS_${PN} = "gpe-applauncher gpe-phonepanel gpe-session-starter gpe-question xmodmap xdpyinfo xserver-common esd esd-utils"
8 DEPENDS = "matchbox-wm gpe-applauncher gpe-phonepanel gpe-question xmodmap xdpyinfo xserver-common esound"
10 SRC_URI = "${GPE_MIRROR}/gpe-session-scripts-${PV}.tar.gz \
11 file://matchbox-session \
12 file://matchbox-session.vm \
13 file://phonesession \
14 file://disable-composite.xsettings \
15 file://standard-apps.patch;patch=1"
17 PR = "r10"
19 S = "${WORKDIR}/gpe-session-scripts-${PV}"
22 # We assume that x86 means we are building an emulation image
23 do_install_append() {
24 install -d ${D}${sysconfdir}/gpe/xsettings-default.d
25 if [ "${GUI_MACHINE_CLASS}" != "bigscreen" ]; then
26 echo "Gtk/ToolbarStyle:S:icons" > ${D}${sysconfdir}/gpe/xsettings-default.d/toolbar
28 install -d ${D}${sysconfdir}/matchbox
29 install ${WORKDIR}/matchbox-session ${D}${sysconfdir}/matchbox/session
31 install -d ${D}${sysconfdir}/gpe/xsettings-default.d
32 install -m 0644 ${WORKDIR}/disable-composite.xsettings ${D}${sysconfdir}/gpe/xsettings-default.d/disable-composite
34 mv ${D}/usr/bin/gpe-logout ${D}/usr/bin/gpe-logout.matchbox
36 install -d ${D}${sysconfdir}/X11
37 install -m 755 ${WORKDIR}/phonesession ${D}${sysconfdir}/X11/phonesession
40 do_install_append_x86() {
41 install ${WORKDIR}/matchbox-session.vm ${D}${sysconfdir}/matchbox/session
44 pkg_postinst_${PN}() {
45 update-alternatives --install /usr/bin/gpe-logout gpe-logout /usr/bin/gpe-logout.matchbox 10
48 pkg_postrm_${PN}() {
49 update-alternatives --remove gpe-logout /usr/bin/gpe-logout.matchbox
52 # This makes use of GUI_MACHINE_CLASS, so set PACKAGE_ARCH appropriately
53 PACKAGE_ARCH = "${MACHINE_ARCH}"
55 SRC_URI[md5sum] = "774c64ed54455f1297ecbeeffdc52eed"
56 SRC_URI[sha256sum] = "da051f5049d44415fff02b48368db4e3e3b6154135a50f990844d73896d18e19"