libdmx: Add fso-specs to DEPENDS
[openembedded.git] / recipes / giac / giac_0.8.4.bb
blob8ebcb2528fdd8183a2eeeff304032d9998287921
1 DESCRIPTION = "A free computer algebra system"
2 HOMEPAGE = "http://www-fourier.ujf-grenoble.fr/~parisse/giac.html"
3 SECTION = "console/utils"
4 PRIORITY = "optional"
5 LICENSE = "GPL"
6 DEPENDS = "fltk gmp mpfr gsl"
8 SRC_URI = "ftp://ftp-fourier.ujf-grenoble.fr/xcas/giac-${PV}.tar.gz"
10 inherit autotools
12 PARALLEL_MAKE = ""
14 TARGET_CC_ARCH += "${LDFLAGS}"
16 do_configure() {
17 sed -i -e s:doc::g ${S}/Makefile.am
18 oe_runconf
19 sed -i -e s:doc::g ${S}/Makefile
22 do_install () {
23 oe_runmake prefix="${D}${prefix}" \
24 bindir="${D}${bindir}" \
25 libdir="${D}${libdir}" \
26 includedir="${D}${includedir}" \
27 install
30 PACKAGES += " libgiac libxcas"
32 FILES_${PN} = "${bindir} \
33 ${datadir}/${PN} \
34 ${datadir}/application* \
35 ${datadir}/pixmaps \
38 FILES_libgiac = "${libdir}/libg*.so.*"
39 FILES_libxcas = "${libdir}/libx*.so.*"
41 SRC_URI[md5sum] = "c0bdb493cfef3dd058cc3750101a4f47"
42 SRC_URI[sha256sum] = "354923541221670d48ea2d713abd3fcad94e7f0d220ac9d53e9bcee0eda6ed4a"