libdmx: Add fso-specs to DEPENDS
[openembedded.git] / recipes / freetype / freetype_2.3.9.bb
blob031923bb81ea7c3b1d625c87c1effe3fb0751a1f
1 DESCRIPTION = "Freetype font rendering library"
2 SECTION = "libs"
3 LICENSE = "freetype"
4 PR = "r1"
6 SRC_URI = "\
7 ${SOURCEFORGE_MIRROR}/freetype/freetype-${PV}.tar.bz2 \
8 file://no-hardcode.patch;patch=1 \
9 file://fix-configure.patch;patch=1 \
10 file://libtool-tag.patch;patch=1 \
12 S = "${WORKDIR}/freetype-${PV}"
14 inherit autotools pkgconfig binconfig
16 LIBTOOL = "${HOST_SYS}-libtool"
17 EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
18 EXTRA_OECONF = "--without-zlib"
20 do_configure() {
21 cd builds/unix
22 libtoolize --force --copy
23 gnu-configize --force
24 aclocal -I .
25 autoconf
26 cd ${S}
27 oe_runconf
30 do_compile_prepend() {
31 ${BUILD_CC} -o objs/apinames src/tools/apinames.c
34 BBCLASSEXTEND = "native"
36 FILES_${PN} = "${libdir}/lib*.so.*"
37 FILES_${PN}-dev += "${bindir}"
39 SRC_URI[md5sum] = "d76233108aca9c9606cdbd341562ad9a"
40 SRC_URI[sha256sum] = "51a033bce9904d73e0821e8e2bba24bd319619d7d1b2e9eeccac611580242ab6"