libdmx: Add fso-specs to DEPENDS
[openembedded.git] / recipes / freetype / freetype_2.3.11.bb
blob32d3f19d950609730e554dd95822aafb8ac884e0
1 DESCRIPTION = "Freetype font rendering library"
2 SECTION = "libs"
3 LICENSE = "freetype"
4 PR = "r0"
6 SRC_URI = "\
7 ${SOURCEFORGE_MIRROR}/freetype/freetype-${PV}.tar.bz2 \
8 file://no-hardcode.patch;patch=1 \
9 file://fix-configure.patch;patch=1 \
10 file://libtool-tag.patch;patch=1 \
12 S = "${WORKDIR}/freetype-${PV}"
14 inherit autotools pkgconfig binconfig
16 LIBTOOL = "${HOST_SYS}-libtool"
17 EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
18 EXTRA_OECONF = "--without-zlib"
20 do_configure() {
21 cd builds/unix
22 libtoolize --force --copy
23 gnu-configize --force
24 aclocal -I .
25 autoconf
26 cd ${S}
27 oe_runconf
30 do_compile_prepend() {
31 ${BUILD_CC} -o objs/apinames src/tools/apinames.c
34 BBCLASSEXTEND = "native"
36 FILES_${PN} = "${libdir}/lib*.so.*"
37 FILES_${PN}-dev += "${bindir}"
39 SRC_URI[md5sum] = "519c7cbf5cbd72ffa822c66844d3114c"
40 SRC_URI[sha256sum] = "8a033b1e6018a1e9ea381b09b2347b02c6686bdf7e4ee86a6714b6b90f1e2ec9"