libdmx: Add fso-specs to DEPENDS
[openembedded.git] / recipes / ekiga / ekiga_git.bb
blob91e73d26ff54e1c8f9e77759f1c8fb0a4bb8a7fc
1 DESCRIPTION = "Gnome videoconferencing application"
2 LICENSE = "GPLv2"
4 ARM_INSTRUCTION_SET = "arm"
6 DEFAULT_PREFERENCE = "1"
7 PV = "3.3.1+git"
8 PR = "r3+gitr${SRCREV}"
9 SRCREV = "c81cabbee7901b6643907d08f9a530308044ec22"
11 inherit gnome
13 SRC_URI = "git://git.gnome.org/ekiga;protocol=git;branch=master \
14 file://rgb16.patch;patch=1 \
17 S = "${WORKDIR}/git"
19 DEPENDS += " boost avahi libnotify eds-dbus libgnome gtkmm libsigc++-2.0 gstreamer gst-plugins-good gst-plugins-base gst-plugins-bad opal ptlib gnome-doc-utils"
20 RDEPENDS += "gst-plugin-app gst-plugin-video4linux2 opal ptlib"
22 EXTRA_OECONF = " \
23 # --enable-static-libs \
24 --disable-ldap \
25 --disable-gnome \
26 --enable-gstreamer \
27 --disable-gdu \
28 --disable-scrollkeeper \
29 --with-boost-signals=boost_signals-mt \
32 do_configure_prepend() {
33 touch gnome-doc-utils.make
36 do_configure_append() {
37 find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
38 find ${S} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g
41 FILES_${PN}-dbg += "${libdir}/ekiga/*/plugins/.debug ${libdir}/ekiga/*/.debug"
42 FILES_${PN} += "${datadir}/dbus-1 ${datadir}/icons"