libdmx: Add fso-specs to DEPENDS
[openembedded.git] / recipes / classpathx / gnujaf_1.1.1.bb
blobf8f644062427450a3bca289ec006dc2a327c228f
1 DESCRIPTION = "Provides a mean to type data and locate components suitable for performing various kinds of action on it."
2 LICENSE = "GPL + library exception"
3 AUTHOR = "GNU ClasspathX"
5 SRC_URI = "\
6 http://ftp.gnu.org/gnu/classpathx/activation-${PV}.tar.gz \
7 file://datadir_java.patch;patch=1 \
10 # java-library must be last (it defines do_stage)
11 inherit autotools java-library
13 S = "${WORKDIR}/activation-${PV}"
15 DEPENDS = "fastjar-native"
17 export JAVAC = "javac"
19 # Fake javadoc
20 export JAVADOC = "true"
22 JARFILENAME = "activation-${PV}.jar"
23 ALTJARFILENAMES = "activation.jar gnujaf.jar"
25 do_compile() {
26 mkdir -p build
28 javac -sourcepath source -d build `find source -name "*.java"`
30 fastjar -C build -c -f ${JARFILENAME} .
33 do_install() {
34 java_install
37 SRC_URI[md5sum] = "de50d7728e8140eb404f2b4554321f8c"
38 SRC_URI[sha256sum] = "b1b5ef560d30fcb11fbf537246857d14110ce4eb2b200d4c54690472305d87b7"