libdmx: Add fso-specs to DEPENDS
[openembedded.git] / recipes / busybox / busybox_1.13.2.bb
blobd22819e7d4b5820ff904a0160249792996b21982
1 require busybox.inc
2 PR = "${INC_PR}.1"
4 SRC_URI = "\
5 http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
6 file://busybox-1.13.2-awk.patch;patch=1 \
7 file://busybox-1.13.2-depmod.patch;patch=1 \
8 file://busybox-1.13.2-init.patch;patch=1 \
9 file://busybox-1.13.2-killall.patch;patch=1 \
10 file://busybox-1.13.2-mdev.patch;patch=1 \
11 file://busybox-1.13.2-modprobe.patch;patch=1 \
12 file://busybox-1.13.2-printf.patch;patch=1 \
13 file://busybox-1.13.2-syslogd.patch;patch=1 \
14 file://busybox-1.13.2-tar.patch;patch=1 \
15 file://busybox-1.13.2-top24.patch;patch=1 \
16 file://busybox-1.13.2-unzip.patch;patch=1 \
17 file://busybox-1.13.2-wget.patch;patch=1 \
19 file://udhcpscript.patch;patch=1 \
20 file://udhcpc-fix-nfsroot.patch;patch=1 \
21 file://B921600.patch;patch=1 \
22 file://get_header_tar.patch;patch=1 \
23 file://busybox-appletlib-dependency.patch;patch=1 \
24 file://find-touchscreen.sh \
25 file://busybox-cron \
26 file://busybox-httpd \
27 file://busybox-udhcpd \
28 file://default.script file://simple.script \
29 file://hwclock.sh \
30 file://mount.busybox \
31 file://mountall \
32 file://syslog \
33 file://syslog.conf \
34 file://umount.busybox \
35 file://defconfig \
36 file://mdev \
37 file://mdev.conf \
39 SRC_URI[tarball.md5sum] = "9e2a604d18bef219a5a6bf3acf78b9e1"
40 SRC_URI[tarball.sha256sum] = "927774408bd982dd246fb716bb2e646ab0708ce321b42c5e271dc98c1f5d1dc8"
42 EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX}"
44 do_configure_prepend () {
45 if [ "${TARGET_ARCH}" = "avr32" ] ; then
46 sed -i s:CONFIG_FEATURE_OSF_LABEL=y:CONFIG_FEATURE_OSF_LABEL=n: ${WORKDIR}/defconfig
50 do_install_append() {
51 install -m 0644 ${WORKDIR}/mdev.conf ${D}${sysconfdir}/
52 install -d ${D}${sysconfdir}/init.d/
53 install -d ${D}${sysconfdir}/mdev
54 install -m 0755 ${WORKDIR}/find-touchscreen.sh ${D}${sysconfdir}/mdev/
55 install -m 0755 ${WORKDIR}/mdev ${D}${sysconfdir}/init.d/