libdmx: Add fso-specs to DEPENDS
[openembedded.git] / recipes / blueman / blueman_1.21.bb
blob337d30f1812a89d57e33b9bc415a8e156f4c1150
1 DESCRIPTION = "GTK+ Bluetooth Manager, designed for common bluetooth tasks."
2 HOMEPAGE = "http://blueman-project.org/"
3 SECTION = "optional"
5 DEPENDS = "gtk+ glib-2.0 bluez4 intltool python \
6 python-native python-pyrex \
7 startup-notification \
10 RDEPENDS = "python-dbus python-pygobject python \
11 dbus bluez4 python-pygtk obex-data-server \
14 PR = "r1"
16 SRC_URI = "http://download.tuxfamily.org/blueman/blueman-${PV}.tar.gz"
18 inherit autotools pkgconfig python-dir
20 EXTRA_OECONF += "--with-no-runtime-deps-check"
22 do_configure_prepend() {
23 sed -i "s/py_prefix=.*$/py_prefix=\"${@"${STAGING_DIR_TARGET}".replace("/","\/")}\/usr\"/" ${S}/acinclude.m4
24 sed -i "s/py_exec_prefix=.*$/py_exec_prefix=\"${@"${STAGING_DIR_TARGET}".replace("/","\/")}\/usr\"/" ${S}/acinclude.m4
27 FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/.debug"
28 FILES_${PN} += "${libdir} ${datadir}"
30 BLUEZ_LIBS = "-L${libdir} -lbluetooth"
31 BLUEZ_CFLAGS = "-I${includedir}"
33 SRC_URI[md5sum] = "26b70341b3d3da28da62c917c8b20377"
34 SRC_URI[sha256sum] = "86200dab50b1595c9a9537586c07de90ccfa084b954bb74f3e8732cc000fe3af"