libdmx: Add fso-specs to DEPENDS
[openembedded.git] / recipes / blueman / blueman_1.10.bb
blobde83f15eec115a1f663057cb974bc5636db48875
1 DESCRIPTION = "Blueman is a GTK+ Bluetooth Manager"
2 HOMEPAGE = "http://www.blueman-project.org/"
3 SECTION = "optional"
4 DEPENDS = "gtk+ glib-2.0 bluez4 intltool python python-native python-pyrex startup-notification"
5 RDEPENDS = "python-dbus python-pygobject python dbus bluez4 python-pygtk python-notify obex-data-server \
8 PR = "r1"
10 inherit autotools pkgconfig python-dir
12 EXTRA_OECONF += "--with-no-runtime-deps-check"
14 BLUEZ_LIBS = "-L${libdir} -lbluetooth"
15 BLUEZ_CFLAGS = "-I${includedir}"
17 SRC_URI = "\
18 http://download.tuxfamily.org/blueman/blueman-${PV}.tar.gz\
21 FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/.debug"
22 FILES_${PN} += "${libdir} ${datadir}"
24 do_configure_prepend() {
25 sed -i "s/py_prefix=.*$/py_prefix=\"${@"${STAGING_DIR_TARGET}".replace("/","\/")}\/usr\"/" ${S}/acinclude.m4
26 sed -i "s/py_exec_prefix=.*$/py_exec_prefix=\"${@"${STAGING_DIR_TARGET}".replace("/","\/")}\/usr\"/" ${S}/acinclude.m4
29 SRC_URI[md5sum] = "f9058305c42038678d5023fcabba22a4"
30 SRC_URI[sha256sum] = "f4a92834a538dc9dbb93fde76933e849b24639faa1721b24549f209b8b590f71"