grub: Split the grub-install script and friends into a separate package.
[openembedded.git] / recipes / grub / grub_0.97.bb
blob40adff9ee97f0ceb9ec243791edc329289843e33
1 DESCRIPTION = "GRand Unified Bootloader"
2 HOMEPAGE = "http://www.gnu.org/software/grub"
3 SECTION = "bootloaders"
4 PRIORITY = "optional"
5 RDEPENDS_${PN}-install = "diffutils"
6 PR = "r5"
8 SRC_URI = "ftp://alpha.gnu.org/gnu/grub/grub-${PV}.tar.gz \
9 file://automake-1.10.patch;patch=1 \
10 file://menu.lst"
12 inherit autotools
14 do_install_append() {
15 install -m 0644 -D ${WORKDIR}/menu.lst ${D}/boot/grub/menu.lst
17 # Copy stage1/1_5/2 files to /boot/grub
18 GRUB_TARGET_ARCH=$(echo ${TARGET_ARCH} | sed -e 's/.86/386/')
19 install -m 0644 \
20 ${D}/${libdir}/grub/${GRUB_TARGET_ARCH}${TARGET_VENDOR}/* \
21 ${D}/boot/grub/
24 PACKAGES =+ "${PN}-install ${PN}-eltorito"
26 FILES_${PN}-install = " \
27 ${sbindir}/grub-install \
28 ${sbindir}/grub-terminfo \
29 ${sbindir}/grub-md5-crypt \
30 ${bindir}/mbchk \
31 ${libdir}/grub \
33 FILES_${PN}-eltorito = "/boot/grub/stage2_eltorito"
34 FILES_${PN} += "/boot"
36 COMPATIBLE_HOST = "i.86.*-linux"