libattr: remove libattr because it is clashing with udev/attr and is not used by...
[openembedded.git] / recipes / python / python-scons_1.3.0.bb
blob792e3a54f77ad30fc1bd31259606bc4700590781
1 DESCRIPTION = "A Software Construction Tool"
2 SECTION = "devel/python"
3 PRIORITY = "optional"
4 LICENSE = "GPL"
5 SRCNAME = "scons"
7 SRC_URI = "${SOURCEFORGE_MIRROR}/scons/scons-${PV}.tar.gz;name=scons \
8 file://toolchain-from-env.SConscript \
10 SRC_URI[scons.md5sum] = "ad6838c867abd2ad5bf371b353d594f7"
11 SRC_URI[scons.sha256sum] = "4bde47b9a40fe767f089f5996d56b6e85a2d4929309b9c07a2dff363a78b0002"
13 S = "${WORKDIR}/${SRCNAME}-${PV}"
15 inherit distutils
17 do_install_append() {
18 install -d ${D}${datadir}/scons/
19 install -m 0644 ${WORKDIR}/toolchain-from-env.SConscript ${D}${datadir}/scons/
22 NATIVE_INSTALL_WORKS = "1"
23 BBCLASSEXTEND = "native"