libattr: remove libattr because it is clashing with udev/attr and is not used by...
[openembedded.git] / recipes / python / python-native_2.6.4.bb
blob4205312978728f6d3f4bd7348c2403aa96fe72bd
1 require python.inc
2 DEPENDS = "openssl-native bzip2-full-native zlib-native readline-native"
3 PR = "${INC_PR}.3"
5 SRC_URI = "\
6 http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2;name=archive \
7 file://00-fix-bindir-libdir-for-cross.patch \
8 file://04-default-is-optimized.patch \
9 file://05-enable-ctypes-cross-build.patch \
10 file://06-ctypes-libffi-fix-configure.patch \
11 file://10-distutils-fix-swig-parameter.patch \
12 file://11-distutils-never-modify-shebang-line.patch \
13 file://12-distutils-prefix-is-inside-staging-area.patch \
14 file://debug.patch \
15 file://nohostlibs.patch \
17 S = "${WORKDIR}/Python-${PV}"
19 SRC_URI[archive.md5sum] = "fee5408634a54e721a93531aba37f8c1"
20 SRC_URI[archive.sha256sum] = "dad8d5575144a210d5cc4fdbc40b8a26386e9cdb1ef58941bec0be02c7cb9d89"
22 inherit native
24 EXTRA_OEMAKE = '\
25 BUILD_SYS="" \
26 HOST_SYS="" \
27 LIBC="" \
28 STAGING_LIBDIR=${STAGING_LIBDIR_NATIVE} \
29 STAGING_INCDIR=${STAGING_INCDIR_NATIVE} \
32 do_stage_append() {
33 install -m 0755 Parser/pgen ${STAGING_BINDIR_NATIVE}/pgen