1 DESCRIPTION
= "Custom Matchbox session files for Openmoko"
4 RDEPENDS_$
{PN
} = "matchbox-panel-2 openmoko-common2 openmoko-today2 openmoko-dialer2"
5 RCONFLICTS_$
{PN
} = "openmoko-session matchbox-common"
10 file://matchbox-session \
15 inherit update
-alternatives
18 install
-d $
{D
}$
{bindir
}
19 install
-m
0655 $
{WORKDIR
}/matchbox
-session $
{D
}$
{bindir
}
20 install
-d $
{D
}$
{sysconfdir
}
21 cp
-R $
{S
}/etc
/* $
{D
}$
{sysconfdir
}
22 rm
-fR $
{D
}$
{sysconfdir
}/.svn
23 rm
-fR $
{D
}$
{sysconfdir
}/matchbox
/.svn
24 chmod
-R
755 $
{D
}$
{sysconfdir
}/
29 pkg_postinst_openmoko
-session2
() {
31 if [ "x$D" != "x" ]; then
35 gconftool
-2 --config
-source
=xml
::$D$
{sysconfdir
}/gconf
/gconf.xml.defaults
--direct
--type string --set
/desktop
/poky
/interface
/theme Moko
36 gconftool
-2 --config
-source
=xml
::$D$
{sysconfdir
}/gconf
/gconf.xml.defaults
--direct
--type string --set
/desktop
/poky
/interface
/icon_theme openmoko
-standard
37 gconftool
-2 --config
-source
=xml
::$D$
{sysconfdir
}/gconf
/gconf.xml.defaults
--direct
--type string --set
/desktop
/poky
/interface
/font_name
"Sans 5"
38 gconftool
-2 --config
-source
=xml
::$D$
{sysconfdir
}/gconf
/gconf.xml.defaults
--direct
--type string --set
/desktop
/poky
/interface
/wallpaper $
{datadir
}/pixmaps
/wallpaper.png
39 gconftool
-2 --config
-source
=xml
::$D$
{sysconfdir
}/gconf
/gconf.xml.defaults
--direct
--type bool
--set
/desktop
/poky
/interface
/digital_clock
1
40 gconftool
-2 --config
-source
=xml
::$D$
{sysconfdir
}/gconf
/gconf.xml.defaults
--direct
--type int --set
/desktop
/poky
/peripherals
/mouse
/drag_threshold
8
41 gconftool
-2 --config
-source
=xml
::$D$
{sysconfdir
}/gconf
/gconf.xml.defaults
--direct
--type int --set
/desktop
/openmoko
/neod
/power_management
2
42 # gstreamer audio settings
43 gconftool
-2 --config
-source
=xml
::$D$
{sysconfdir
}/gconf
/gconf.xml.defaults
--direct
-t
string --set
/system
/gstreamer
/0.10/default/audiosink pulsesink
44 gconftool
-2 --config
-source
=xml
::$D$
{sysconfdir
}/gconf
/gconf.xml.defaults
--direct
-t
string --set
/system
/gstreamer
/0.10/default/audiosrc pulsesrc
48 ALTERNATIVE_NAME
= "x-window-manager"
49 ALTERNATIVE_PATH
= "${bindir}/matchbox-session"
50 ALTERNATIVE_LINK
= "${bindir}/x-window-manager"
51 ALTERNATIVE_PRIORITY
= "11"
53 CONFFILES_$
{PN
} = "${sysconfdir}/matchbox/session"