libattr: remove libattr because it is clashing with udev/attr and is not used by...
[openembedded.git] / recipes / mozilla / rhino_1.7r1.bb
blobb7b5d9e7d26d6c8b6c465e011aed362ae110c405
1 DESCRIPTION = "Lexical analyzer generator for Java"
3 LICENSE = "GPL MPL"
5 DEPENDS = "fastjar-native"
7 inherit java-library
9 SRC_URI = "\
10 ftp://ftp.mozilla.org/pub/mozilla.org/js/rhino1_7R1.zip \
11 file://rhino \
12 file://rhino-jsc \
15 S = "${WORKDIR}/rhino1_7R1"
17 PACKAGES = "${JPN} rhino"
19 FILES_${PN} = "${bindir}/rhino ${bindir}/rhino-jsc"
20 RDEPENDS_${PN} = "java2-runtime ${JPN}"
22 do_compile() {
23 mkdir -p build
25 # Compatibility fix for jamvm which has non-genericised
26 # java.lang classes. :(
27 bcp_arg="-bootclasspath ${STAGING_DATADIR_NATIVE}/classpath/glibj.zip"
29 javac $bcp_arg -source 1.5 -sourcepath src -d build `find src -name "*.java"`
31 mkdir -p build/org/mozilla/javascript/resources
32 cp src/org/mozilla/javascript/resources/*.properties build/org/mozilla/javascript/resources
34 fastjar -m ${S}/src/manifest -C build -c -f ${JARFILENAME} .
37 do_install_append() {
38 install -d ${D}${bindir}
40 install -m 0755 ${WORKDIR}/rhino ${D}${bindir}
41 install -m 0755 ${WORKDIR}/rhino-jsc ${D}${bindir}
44 SRC_URI[md5sum] = "613eed8201d37be201805e5048ebb0c3"
45 SRC_URI[sha256sum] = "084e250d2392369b2548b663e61bcf128baecb2f527e381e9ba89f0148db2c0d"