1 DESCRIPTION
= "Lexical analyzer generator for Java"
5 DEPENDS
= "fastjar-native"
10 ftp://ftp.mozilla.org/pub/mozilla.org/js/rhino1_7R1.zip \
15 S
= "${WORKDIR}/rhino1_7R1"
17 PACKAGES
= "${JPN} rhino"
19 FILES_$
{PN
} = "${bindir}/rhino ${bindir}/rhino-jsc"
20 RDEPENDS_$
{PN
} = "java2-runtime ${JPN}"
25 # Compatibility fix
for jamvm which has non
-genericised
26 # java.lang classes.
:(
27 bcp_arg
="-bootclasspath ${STAGING_DATADIR_NATIVE}/classpath/glibj.zip"
29 javac $bcp_arg
-source
1.5 -sourcepath src
-d build `find src
-name
"*.java"`
31 mkdir
-p build
/org
/mozilla
/javascript
/resources
32 cp src
/org
/mozilla
/javascript
/resources
/*.properties build
/org
/mozilla
/javascript
/resources
34 fastjar
-m $
{S
}/src
/manifest
-C build
-c
-f $
{JARFILENAME
} .
38 install
-d $
{D
}$
{bindir
}
40 install
-m
0755 $
{WORKDIR
}/rhino $
{D
}$
{bindir
}
41 install
-m
0755 $
{WORKDIR
}/rhino
-jsc $
{D
}$
{bindir
}
44 SRC_URI
[md5sum
] = "613eed8201d37be201805e5048ebb0c3"
45 SRC_URI
[sha256sum
] = "084e250d2392369b2548b663e61bcf128baecb2f527e381e9ba89f0148db2c0d"